Help with routine

Hi all,
I have a “Good Morning” routine in RM4 which works well and it set at a certain time to run. All good.

I’m going away in a couple of weeks so thought I would add some limitations to it so it only runs when in certain modes ie when not in “Away” or “Vacation” mode. So in the “Manage or create Conditions” field I’ve added the modes I don’t want the rule to run in.

Maybe I’ve misunderstood but the rule continues to run even when the mode is in Away/Vacation and it shouldn’t. I’ve tried modes it should run in and NOT modes but either way the Good Morning routine still runs.

Any ideas?

Think I’ve found the answer. The Manage Conditions box doesn’t actually do anything D’oh so I will need to build actions into my rule.

2 Likes

I think predicates would be the answer in rm5, but if you want to stick with what you know in rm4, then conditional actions are what you are after.

Also don't forget you can cut and paste actions, if you need to shuffle your existing actions around

1 Like

Yeah I was about to say "Try RM5" lol

1 Like

I'd be a little hesitant to taking on such a change before going away, given the simplicity of setting this up in rm4 (nothing against rm5, just a general approach I would take)

1 Like

Maybe this is a stupid question... but... how?

I'm not near my PC at the moment, otherwise I would grab a screenshot, but I'm pretty sure there are some buttons / drop-down lists for cut and paste when editing the list of actions for the rule.

2 Likes

OMG! I have honestly never noticed that before! I've been doing it the hard way all this time. Thank you!

1 Like

All good - just added the conditional actions and the limited modes and now working as it should.

Thx for the tips above

1 Like