Help with Plus Leviton DZPD3 devices

I thought this was solved a few versions ago. I have a Plus Leviton DZPD3 that was on my C4. Tried to move it to my new C7 and the first time it connected it showed up as a fan controller. I changed it to Generic ZWave dimmer as it was on my C4. After a couple of iterations of (unsuccessful ) attempts it will no longer link with either my C4 or C7`. I also have a non plus version of the same device and I cannot get to work either. It links to the C7, and can bee controlled (on, off and level) from the device page but there is no status update. I can see the device change but no updates at all on device page. Any ideas on how to fix my new bricks? these devices had been working for more than a year.

Doesn't sound like a device issue but a driver issue.

Yeah, I changed the driver to Generic Z-Wave CentralScene Dimmer and it now works. Just a little disappointed the device mis-identified the proper driver. This started about 2 years ago when the device was paired as a fan dimmer. Got corrected and now mis-identified again. Minor issue so I'm not overly concerned, but thank you for reminding me to update the post.

1 Like

It seems like that every time that name comes up, there is some driver issue. What works for someone doesn't work for another. Not sure why? But there have been tons of Leviton issues on the forums in the past couple years.

The problem is usually the driver. I believe there is something in the Hubitat that thinks the device is a fan speed instead of a dimmer.

As far as ZWave Spec is concerned they are both MultiLevel Switches.

Yeah, a lot from me. When I first included it showed as a fan control , but everything worked. Then someone updated the fan control driver and it stop working. Mike fixed the issue and no problems until I moved them to my new C7.
Bit it's all good now so I'll go back to sleep. :laughing: