Help needed with motion lighting rule

I'm trying to write a rule that turns on a dimmer to a low level in response to motion at night and any change in the dimmer level causes the rule to be suspended. If turned off manually, the motion detector status should be ignored either for a short time (1min) or until they go idle, so that leaving the room will not turn on the light again.

The switch that should override the rule is a Lutron dimmer. The dimmer is integrated in HE and the light can be controlled as a device in HE.

Sounds like a simple job for Motion Lighting, and I've got the following:

That works fine to turn the lights on at 15% in response to either motion detector becoming active, and the lights are properly turned off by the rule after the motion detectors are inactive.

The rule is currently paused because of these problems:

  1. When the dimmer level is changed via the physical Lutron switch, the rule automation is not suspended (ie., if the motion detector becomes active, the light is lowered to 15%, when the motion detector becomes inactive, the light is turned off).

  2. When the light is turned on via the dimmer switch outside of the (Sunset-30m to Sunrise+30m) time period, the Mode Lighting rule turns off the light when the motion detectors are idle.

Any suggestions?

If the rule doesn’t work properly in Motion Lightning, have you tried Rule Machine?

I have....without success. If I understand the Motion Lighting app correctly, it should be sufficient for this action.

Okay. I’m way more familiar with RM than Motion Lightning. If you decide to go back to using RM and need help debugging the rule, let me know!

Couple things I would try. First remove the "Switches to activate on" Second your time restrictions I think are only restricting the ON and not the OFF. so you could also add that to additional options for lights-off

Thanks for the suggestions.

Huh. That's kind of the opposite of what @marktheknife is suggesting in a similar thread.

Done -- added a time restriction for when the lights should be turned off -- I'll see if that helps during the day, but the problem with the rule ignoring changes in the dimmer level persists.

I tested with a very simple setup using Lutron and everything works as I expected. Here is the ML config:

and here is the log result. I triggered the light and then adjusted manually from the switch the level.

Download the Hubitat app