Having some issues with Monoprice Z-Wave Plus Recessed Door Sensor #15268

I have two of these recessed door sensors in my front and back doors and they were working fine with SmartThings, but after I excluded them and added them to HE, they are detected during inclusion as simply "Device" and when I switch them to Generic Z-Wave Contact Sensor, they just show up as status unknown on my dashboard. Total HE newbie here, any help?

I found these needed to be somewhat near to the hub to include properly. It can take a good few seconds to fully initialize. Also worth trying is to put HE in exclude mode and exclude them from HE before including them. Even if they were never included on HE, it ensures the devices are excluded from everything as much as possible. Once included, you can put back in the doors, and assuming you have decent z-wave mesh, they are pretty reliable and battery life seems good.

I'm having this same issue. I've Included it and Excluded countless times within inches of my HE, it pairs as Device.

It's a brand new unit.

Are you saving it and then going to the new device and selecting the Generic Z-Wave Contact Sensor driver, saving it, and hitting the configure button on that page?

It may not be recognized because a new batch may have a slightly different "fingerprint" from the one that was used to develop the driver.

Yes, I tried that.

Then I put it up against the magnet to try to log some events - nothing registers.

Saved As DEVICE:

Saved As Generic Z-Wave Contact Sensor (strange that is still shows a Zigbee Id even though added as Z-Wave):

No Events :frowning:

I don't see what you are describing with the Zigbee ID but no matter.

Here's what that sensor Device page should look like when the device is paired and functioning (I have one outdoors on one of my gates).

When I hit Configure on the device page, I see this in the Logs:

image

Configure gets me a temperature to show up in the Events and as a Current State.
image

I get the same thing on the Logs when I hit Configure.

Under Scheduled Jobs I have this:

I've tried sticking the magnet against it and pulling it off multiple times, never shows a Contact state like yours does.

Okay! I figured out the trick and putting it here for the next lost soul!

You have to push down the tamper switch (or put it back together completely), then stick the magnet up to it in order to get it to pull all the other Current States.

I'm fully functional now:
image

2 Likes

Those and the Aeotec recessed sensors have the tamper switch.

I have the same type device (purchased as Vision Z-Wave PLUS Recessed Door and Window Sensor ZD2105) but mine seems to be very slow in getting back open and closed state. After I added an Aeotec Range Extender 6 it did not improve.

Has anyone else tried using this with this kind of an issue?

Make sure that you have not joined it in secure mode, or else they perform very poorly.

Got mine paired perfectly:

  • Disassembled and inserted battery, left circuit board out of housing
  • HE in inclusion mode
  • Pressed tamper button
  • HE paired as "Device", set the name and changed driver to "Generic Z-Wave Contact Sensor"
  • Put the sensor back together (with the top cap effectively holding the "tamper" switch)

Battery and contact working great and this sensor is lightning fast to respond to state changes.

Now to get the courage to drill the holes in my 3 doors lol

Playing around with this, any ideas on this potential issue?

I’ve got the two pieces this far apart and it still reads as “closed”... I could totally see a door cracked open and still have the parts that close to read as “closed”

The reed switch on these devices is around half way down the cylinder on the side. You can see it as a small black "cuboid" on the circuit board when you remove it to install the battery. You might try rotating the case of the sensor away from the magnet.