Has anyone gotten the tuya humidity/temp/ light sensor working with Hubitat

@snell do you think it’s worth order?

Totally up to you. If you get one, it has no guarantees of course, but I volunteer to try to make a usable driver for it at least.

Thx from that thread it seems impossible or am I reading it wrong?

That other thread does say they got it working. ZigBee is more usable (in my book) with Tuya devices than their cloud/WiFi devices.

1 Like

Hi,

I’m trying to use this same device, but so far I’m not having much luck. I’ve tried the related built-in drivers as well as the @snell Air Sensor Driver and the @pfmiller driver listed above (Tuneway Tuya Temp/Humidity Sensor).

When I try the Air Sensor Driver I see the following log entry:

dev:782021-07-23 20:36:31.664 debugDiagnostic enviro2 - Unhandled cluster. 0400 is Luminance measurement, descMap = [raw:1EBB0104000A0000210000, dni:1EBB, endpoint:01, cluster:0400, size:0A, attrId:0000, encoding:21, command:0A, value:0000, clusterInt:1024, attrInt:0]

When I try the Tuneway Tuya Temp/Humidity Sensor driver I see:

dev:782021-07-23 20:33:01.916 debugReturning empty map

dev:782021-07-23 20:33:01.912 debugParse returned [:]

dev:782021-07-23 20:33:01.909 warnNo condition matched: clusterInt: 1024; commandInt: null

dev:782021-07-23 20:33:01.906 debugdescription: read attr - raw: 1EBB0104000A0000210000, dni: 1EBB, endpoint: 01, cluster: 0400, size: 0A, attrId: 0000, encoding: 21, command: 0A, value: 0000

I am willing to learn how to create a driver for it, but I certainly don’t expect anyone here to hold my hand. I would very much appreciate any form of help anyone may offer to get this thing working : )

~Jerry

I am working creating a specific driver for this device in a separate thread here:

BUT... It is definitely not working well yet and some of the log entries you posted here seem to be what we are seeing with it otherwise. There is the Luminance reported by ZigBee (HOORAH, although the values are odd)... and nothing else. There is a special cluster it is reporting otherwise (I think the one that @pfmiller's driver is looking for and mine is checking) but the data comes back blank or with the exact same value all the time. So it does not appear to actually report the Temperature and Humidity so far.

Hi Jerry, that 0400 cluster you are getting an error for is probably the illuminance data. The device I wrote my driver for is slightly different and didn't include that sensor.

Is the temp and humidity working with my driver? If so it would probably be pretty simple to handle the illuminance too.

That said, it looks like that data being returned is 0, so I'm not sure if handling it would accomplish much.

It is a weird one. Data comes back on 0400 for illuminance (I assume his is dark at that moment). But nothing comes back on 0402 or 0405. It has a manufacturer specific cluster E002 that reports but never seems to change. It also does not appear to report anything on the "normal" Tuya cluster of EF00.

1 Like

Thank you for the replies.

The sensor is in fact sitting in a dark room; which likely explains why 0402 is reporting 0. I have also learned that this device appears to lump both temperature and humidity into one cluster (e002?), so those parameters are not reporting either. Aside from the debug logs the only response I have received from any driver is that the battery is 100%.

In the other related thread mentioned above @JasonJoel said that someone would need to review the payload and use trial and error to figure it out. I would certainly be willing to do this if I knew how. At the end of that thread it looks as if @oscensores got it working, but doesn’t really explain how (something about ZHA).

I’m still researching as well as reading the language reference documentation for Groovy. However given the device has a 30-day return policy (minus a couple of days or so) my time is limited.

FWIW: This is the device fingerprint per Zigbee - Generic Device Toolbox

[dev:78] fingerprint model:"TS0201", manufacturer:"_TZ3000_qaaysllp", profileId:"0104", endpointId:"01", inClusters:"0000,0001,0400,E002", outClusters:"0019,000A", application:"44"

Hi, i'm not sure, but i'am using this sensor from amazon

And i can't fine a driver working with Battery status
I tested the driver from github, thanks a lot for the work by the way.

This driver :

But i only have Temp and humidity, no battery status.

Tried this one?:

My device looks the same and I'm running that driver (can be found through HPM) with all three values presenting.

Thank you so much marcus.soderberg

I just tested it and it work great, many thanks :smiley:

I love Hubitat, even more now :grin:

1 Like

Did you managed to find a suitable driver and get his Tuya Multi Sensor NAS-TH01 working with Hubitat?

I am struggling with this NAS-TH01 as well

Is this the NAS-TH01:

@jtmpush18 @ubatra @mcchey can you try this driver?
I don't have these devices and I am unable to test it.

I don't have the model with the LCD, this is the model that I have:
image

Did you get it working?
If not, you can follow up in this thread: [ALPHA] Tuya Temperature Humidity Illuminance LCD Display with a Clock

Download the Hubitat app