Harmony Hub device control

Hi All,

I have my harmony hub setup in Hubitat and control my actives. I was wonder if there is a way to control just one device.

Thanks

I don't think you can do this with @ogiewon's Logitech Harmony Hub Driver. Because I might be wrong, I've tagged him in this response so I can be corrected.

If you have an RPi or any other computer that is left running all the time and can run NodeJs apps, you can control individual devices controlled by the Harmony hub using this.

I will second this integration, it works perfect for individual device control. Its very easy to setup and send commands. I used this to fully integrate my napoleon alluravision fireplace.

How does this integrate into Hubitat

You can use http commands from Rule Machine, or @ogiewon's http-momentary-switch.

For example, here's an http-momentary-switch called "Blu Ray" that I use to turn my Blu Ray player on/off. It sends an http POST command to harmony-api running on TCP port 8282 of another computer whose IP address is 192.168.1.4. The URL path contains the path to the harmony-api command to control the Blu Ray player device.

Works very well and really is very easy to setup as indicated by @AutoM8

3 Likes

Correct. Currently my Harmony Integration is "Activity Focused", and does not expose individual devices. Adding support for individual Devices feels like a huge can of worms to me. :wink:

I can totally understand that. It's my kitten, Diesel, who does not. Little rascal jumps up on the Blu Ray, and randomly hits buttons until the eject tray pops out. So, I have two momentary switches exposed to Alexa - to close the tray and turn the Blu Ray off. They get used at least once a day.

2 Likes

Can't seem to get Hamony-api working on PI. I'm getting this error.

errorhub { Error: connect ECONNREFUSED 10.10.10.102:5222
at Object.exports._errnoException (util.js:1028:11)
at exports._exceptionWithHostPort (util.js:1051:20)
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1090:14)
code: 'ECONNREFUSED',
errno: 'ECONNREFUSED',
syscall: 'connect',
address: '10.10.10.102',
port: 5222 }
Hub discovered: undefined at undefined.
Hub lost: undefined at undefined.
Hub discovered: undefined at undefined.

Any ideas?

Thanks

Is this the IP address of your Harmony hub? And what is the content of your config.json?

Also, did you enable XMPP on the Harmony hub? If you didn't then, a connection to TCP port 5222 will fail.

Here are instructions on how to enable XMPP:

1 Like

Download the Hubitat app