Groups and Scenes


#61

No, only when you hit the switch or use an automation to turn on the switch. Then it sets the dimmers to the right level for the mode.

For example, if you tell Alexa to turn it on, the lights would come on to the right level for the mode.


#62

Okay nice, exactly what I was looking for. Thanks.


#63

Would this be a possible option in the future, instead of having to enter set percentages?


#64

Questions on scenes:

Some scenes have an option called 'adjust scene settings'. If I copy scene, then go into the copy that option seems to be missing... am I missing something?

When i drill down to 'adjust scene settings' (when it exists) each device has a "Switch on/off?" Three settings, on, off, and empty. What's the logic behind those? i.e. send whatever is in this box regardless of the trigger state, or send on or off (as appropriate to scene's triggered state) along with dimming #...

Switch to diable Scene - I picked one... now I can't unpick it.

Disable when Off? On is default - This disables the scene from running, not an on/off switch to activate (run) scene?

Why are there two devices created? When would I use the 'capture' device vs the other?


#65

All scenes have this, AFTER they have been setup. If you clone a scene, you will get this:

Notice there is not Adjust Scene option. Now if you click Get Clone Values, you get this:

Still no adjust is available. You have to Capture the scene first. Then you get this:

The choices are on or off. Every device in a scene is either on or off. You can pick which. It doesn't send anything until the scene is Activated. It looks as though there is a glitch in the UI in that it should show what the captured on/off state is, but it doesn't do so.

I cannot reproduce the issue of not being able to deselect a disable switch. Just click on the radio button, it should clear.

There are two devices created: One is for Activating the Scene. The other is for doing a Capture. Capture is when a scene is "memorized" based on the then current settings of all of the devices in the Scene. Activate causes all of those devices to be set to their Captured states.


#66

Got it! I'll assume it's a UI thing that'll get worked out and make sense...turns on as well as set level if set to on, and when the scene is de-activated it'll off...

Also, when I add a device to the list after creating the scene, it screws up the listing in that area. i.e. I added "bat signal" to the device list, went back to adjust scene to plug in the values for it, and bat signal has been added to middle(ish) of the list, it's also taken on the values of the device that was in that 'slot' and shifted the remaining devices down. The new device has the value of the device previously in that slot and everything that shifted down now has the value of the previous device.... if that makes sense?


#67

Whoa, that's not intended behavior. Will investigate, but I have an idea what might be causing it.


#68

Last issue for the day -

Got it. The cursor "hot spot" includes the text, (arrow turns to nose picker)... that was my 'target'... the text, not the nose.

When I hit the "bubble", it feels it, when I hit the words I get nothin. So operator error. Thx.


#69

The bug with Adjust Scene after adding another device is fixed in latest release: Hub Update 1.1.6


#70

How do I get a scene's virtual device to reflect the actual state? Or is there a way to activate the scene directly? Long version below-
Thinking about dashboard switches for two scenes and I'd like to see which scene (if any) are . If I 'turn on" scene A, then turn on scene B , be useful if the switch associated with scene A turned off for all sorts a stuff. If I add virtual switch A to the scene B I can't figure out how to tell it to do that first... so it randomly throws in the "A off," result is it starts scene B then turns off scene A... and I'm in the dark... again.
(mostly) all the same devices, just different dim levels.
Feels like this should already be possible, but I can't find it.


#71

It happens automatically. The activator switch is a virtual switch with some special characteristics. One of those is it doesn't matter what state it is in as to its functionality. Whenever you turn in On, it activates the scene. At that moment, the scene is fully set, and the state of the activator switch is On. Now, go behind the scene's back and alter one of the devices in the scene. That will be detected and the activator switch's state will go to Off (such state change will not turn off the devices in the scene). Were you to turn it On, it would restore the scene. But it's state is going to reflect that the scene is or is not fully set.


#72

I wanted the new "Ignore activate switch off?" feature for some of my scenes, so I figured I would clone them to get a new Scene-1.2, delete the original, and rename the new one. In the process, I found a few issues/areas that could be improved. Here's what I did:

  • Selected the scene to clone and then clicked 'Continue'
  • Clicked on the new Scene-1.2 child app in the app list
  • Clicked "Get Clone Values"

In my mind, I thought this would get me two identical scenes. The scene I'm working with is my "Night Mode" scene, which turns off a bunch of lights and turns one bulb on at a level of 1 for a night light.

The new scene that was created just turns them all off, including the one that had been set to [on, level 1].

"No big deal", I thought. It's easy enough to go in and flip that to "on" and set the level. I click on "Adjust Scene Settings" and all of the on/off drop-downs along with the RGB/CT drop-downs are blank and required fields. What should be a few seconds worth of work becomes much more drawn-out, especially needing to wait for a page reload and then scroll back to where I was after each change. If there's a way to populate the adjustment form with the current settings, that would be a huge time-saver when editing a scene.

Once done with that, I then deleted the original scene ("Night Mode") and renamed the new one ("Night Mode copy") to the original name.

The activation and capture devices, however, are still named "Night Mode copy" and "Night Mode copy Capture". Can I safely rename these manually?


#73

I've udpated the box,... now I'm not getting action to happen with any scene I've tried.
Turn on the associated device, log shows that, but then no action to set dimmers with one scene, etc. The log does show lights being 'set' and updating the dashboard, etc but the lights don't actually change. manual each light does work as a device itself. It's like there's a simulate button somewhere I hit...

I'm rushed today, but in case it's a problem in the update wanted to give you a heads up... I've tried just building a new scene and get no action to actually happen though.


#74

Cloning copies the devices over but not their settings. I will see about adding copying their settings as well.

The scrolling in the UI issue is being fixed, coming soon.

You can safely change the names of the devices.


#75

Great! I'm not much of a designer, but the list was tough to parse as I was scrolling through it trying to get back to where I was. It may help if there were a bit more visual distinction of which fields were with which device. Maybe a box around all of the fields for a device, more separation between devices, or both?


#76

Should the scene activation switches be discoverable by Alexa? I added them to the Amazon Echo App, but they don't get discovered when I tell Alexa to "discover devices".


#77

Yes, they are a virtual switch, and should show up as such.


#78

I am trying to set up a simple scene for Watch Theater.
Window shades (2) close.........works ok
Movie screen down.............works ok
Fibaro RGBW 441 lights on............NOT WORK
logs error = 2018-11-07 10:43:40.063:debugsetColor: [hue:0, saturation:100, level:50, rate:null]

I set devices as I wanted and then "captured". When I go to the device "Watch Movie" and press Push, devices behave as I listed above. No lights working.

Apps>Watch Theater> window shows....

Watch Theater (Not Set)
Re-Capture, Activate or Adjust a Scene

Captured:
Window RT: on, level 99
Movie Screen: off
Win RGBW: on, level 50, hue 33.66, sat 100
Mov RGBW: on, level 50, hue 33.66, sat 100
Window LFT: on, level 99


#79

Try setting the transition rate for the Scene to something, like 0 or 1.

What version are you on? There was a bug with transition rate fixed in 1.1.7.


#80

Sorry for the delay, I had to set the transition rate (1)
I'm on 1.1.7.120

BTW, no joy, Lights not turn on.