Group bulbs and Alexa

Previous to new Groups 2.1, I had 3 bulbs (all Sengled) in a group called living room and that shared with Alexa.

I could say “turn on the lights” and it would. Now, I recreated using 2.1 as a Group Dimmers (since they all don’t show under Bulbs). But now saying “turn on the lights” does nothing. I have to say “set lights to 100”. Heck, even on/off under Group device does nothing if they’re off. I have to set the level to turn on. This is likely because my schedule actions and remote just set them to zero, but hitting “on” from that state should turn them to some set level. :confused:

Is there some way to fix this, or convince Alexa that “turn on” means “set to level X”?

Thanks!

Inside the Alexa app you can set up a custom routine that takes your "turn on the lights" and then re-issues the command "set lights to x"...

Been a while since I farted with Alexa but if you change a device from light to switch, I think that changes the On/Off 100/0 thing. Theres been a lot of reported activity with Alexa development recently so maybe things are changing - but I haven't seen anything like that myself

Would that not prevent dimming in Alexa?

Okay. I have tried all 3 “group device types” and all of them result in same behavior.

You can test this in HE (without Alexa). If you set the Group bulbs/dimmer to 0, they are “off”. But if you then say “on” they go to on, but stay at 0 brightness, which is effectively off.

@mike.maxwell any thoughts on this one? I’m a bit stumped here. This didn’t behave this way in the old Groups…

I have an all sengled group using 2.1. All my bulbs are show under 'dimmers'.

They show up under alexa as Group - bulb dimmer


The group shows on Alexa under the devices stack for Bulbs. I can state - Alexa, set office lights to 25% etc. or Alexa, turn off Office.
What driver are you using for the Sengled bulbs? Would any information about my configuration help you?

Same exact setup. So to see what I’m seeing. Set your bulb group to 0. Either via Alexa or HE. HE will state the bulbs are off, and at 0.

Now tell Alexa or the bulb group to turn on. Bulbs will be “on” but at 0.

we're looking into this.

Thank you sir! Sorry I didn’t bring it up sooner. I can reach the pico but my son comes down in the morning and tries to use Alexa and it doesn’t work to just say “on”. :confused:

Thanks!

Download the Hubitat app