Group Bulb Dimmer vs Group Bulb Dimmer-2.1

Any have an idea what the difference is between a device type "Group Bulb Dimmer" vs "Group Bulb Dimmer-2.1"

A quick search on "Group Bulb Dimmer-2.1" didn't come up with hits...

TIA

The Group Bulb Dimmer-2.1 is used by Group-2.1. There were changes made in the way the virtual device interacts with the app, that necessitated a different driver. These changes were needed to support the enhanced indicator functionality of Group 2.1 vs Group 2.0.

I updated to the latest Hubitat version today, and got the errors below which made me investigate...

Is there a need, or any point, to upgrade from Group (2.0) to Group 2.1?
If so, what would the benefits be?

J

PS I am using Group Bulb Dimmer (Group 2.0)

Group 2.1 has less overhead and responds more quickly for me, especially with larger groups of lights (zigbee in my case). I upgraded all of my groups and am very happy with the improvement. Just sharing my experience in case it helps.

Hey all,
I updated one of my groups to 2.1 which is nested in an existing scene and tonight when that scene fired the group didnt activate. I'll check the logs later but is there anything I should be looking out for ?
Also - should I be updating the scenes as well as the groups, cause thats going to be a PIA.

*Solved - for some reason the capture had them down as RGB bulbs but when I changed the captured state back to CT they are working again. I saw in the logs it was trying to set them to Blue with a Hue of X.. which didnt make sense.
All sorted now.

I have just received the C7 today. Upon migration all my devices (TONS of zigbee issues were experienced, they either synced flawlessly, or we determined to drive me insane) and RE creating all my groups and rules, I have found that the groups do not seem to work correctly. I don’t know if it’s a C7 issue, or firmware issue.
Either way, when creating a group it seems to function fine, until any single member is turned off separately from the group. Then that member will no longer respond to the group message for in or off. However, if I set the level, it will then re-sync to the group. However, as soon as any member is turned on or off separately from the group, it becomes lost again. I have tried sever combinations of settings, zigbee group message, on off optimization, without resolution.
I have even tried changing the driver to the non 2.1 group and the Same thing happens.

I've noticed an issue where a group of 2 CREE bulbs using the 2.1 driver does not respond consistently... sometimes one bulb, sometimes the other, sometimes both. I have zigbee optimization turned off. The Cree bulbs are just dimmers... no other controls. Yet the group device seems to want to change the hue, color, etc. Not sure if this is part of the issue... maybe the bulb responds oddly to the command? The cree bulbs are both using the generic zigbee bulb driver.

Any suggestions?

This sounds like the device isn’t reporting its state to the hub correctly. If that is the case, you would want on/off optimization set to off as it relies on reporting of state change, only sending on/off commands to devices that aren’t already in the requested state. It could also be a mesh issue where the commands or reports are not making it to the device or hub.

Do you mean zigbee group messaging, or on/off optimization? Try it with zgm on and optimization off. The Crees are known to be terrible repeaters, so it could be a mesh issue as well.

I had the same issue with both Cree and sengled bulbs. I had to change them to the built in generic zigbee bulb driver and they now work fine.

Group messaging and optimization were both off. I tried un-pairing and re-pairing the bulb and had issues with it. It also reported a low LQI on the getChildAndRouteInfo report so I chucked it and replaced it with a new one. Seems to be behaving. I will turn group messaging on and see how it goes.

1 Like