Graphing / Charting Temp/Power Data

Ok. If I see anything that may help I'll pass it on

Added the below container variable with no luck. Chrome says Grafan refused the connection

1 Like

What's the last one shown as true? I can't see the variable name. As well as the allow embedding and cookie settings there was also the allowing anonymous login.

@sburke781, I've followed your instructions (several times) and I'm not getting the expected display. The graph looks great in a browser window and I'm running InfluxDB and Grafana natively on the same Arch Linux host. I get:

I checked each of the items listed and found no problems.

The device looks like this:

And the code is:
<iframe src="http://redacted:3000/d/gXciQEkMk/environment-sensors?orgId=1&refresh=1m&now-12h&to=now&kiosk" width="900" height="400" frameborder="0"></iframe>

Any idea what's wrong?

Wait...The same dashboard is displaying the graph properly in the Hubitat app on my phone! WTH?

You're probably stretching my knowledge and experience here, it does mention the use of a proxy... could there be something different about how you access the dashboard between your PC (?) and your phone? Could one be a local dashboard link and one be cloud? I'll take another look at my setup in a few hours.

I don't do cloud anything but it's definitely something to do with my home networking. I'll post back here when I figure it out. Thanks for looking.

1 Like

I don't expect this will be related to your problem, but I did have to go through at one point and reassign the owner and group for my Grafana or Influxdb files. It was messing with my ability to start up the services automatically on boot. Perhaps it could be something like that? Though it is still strange that it displays on your phone.

Only other thing I have read is about large numbers of stale connections hanging around... Not sure what it could be...

Saw your post, I too struggled with influxdb, Grafana, etc. In the end, I wrote Hubigraph to accomplish the same thing as InfluxDB and Grafana without a separate hub and providing native dashboard support. It’s no where near perfect, but takes about 5 minutes to set up.


I think it was only timing got in the way of me from using HubGraph, i.e. I took the plunge into a RPi a few months ago, but if HubiGraph was around I certainly would have given that a go first and probably would have ended up using HubiGraph instead. Around the time I setup my RPi I did get a little frustrated and posted on this forum about how it should be esier for all to chart key data, not just something those of us with technical skills can setup. The best I can offer to share my experiences. From what I've seen I think HubiGraph goes a long way to providing that easy entry point. Nice work in developing the app.

1 Like

@LosinIt - I can't see anything that stands out in my setup of the tile. Aside from my use of variables in the URL to limit my sensors, the only other difference is I am using the older code for Tile Master, i.e. prior to the recent smarrly changes. None of that should produce the behaviour you are seeing. I also haven't been able to find anything meaningful for the error you are seeing. Let me know if there's anything you want me to check on my end.


I finally figured it out. It's a browser-specific issue with Vivaldi (a chromium derivative) but may well be found in other browsers as well, I just don't know.

I had to unblock "Insecure content" for the HE site. To do so...


  1. Click on the Site Info icon.
  2. Select "Site settings" from the dropdown that appears which will take you to a page with lots of settings.
  3. Scroll to the bottom and allow "Insecure content"
1 Like

Excellent work, thanks for posting the solution.


Hi Brad2
Could you please let me how you are measuring the water flow through Hubitat. I am asking this because I was looking to improve my water leak detection.
Thank you

I am using a Liquid Flow Meter connected to a Raspberry Pi. I use a bit of Python code there which samples this meter and sends the results to Hubitat (via the Maker API) as well as to an Influx DB. In my case, I am really just interested in the relative change in flow rate over time, as I am monitoring a filter that needs to be cleaned as the flow rate changes. With this I did not need to calibrate the output into any accurate volume measurement.

You can also take a look at StreamLabs for whole home detection. I'm using it now and, while I have doubts as to how accurate it is, it works for my purposes. I'm also hooked into their API to gather metrics in InfluxDB (forewarning: It's about $60 bucks a year to use the API).

Hello Brad2
Thank you for the information. I believe that I need larger flow meter but I took on board the idea of connecting to a Raspberry Pi.

Hello Harold.min
Thank your for letting me know about the StreamLabs. I'll certainly look into this as on shelf solution will save some time. Also, looking to something similar to the solution suggested by Brad2 or even simpler such as having a motion sensor ( narrow beam) pointing to the dial of a pressure meter (installed on the whole of house filter) and combining this with a whole of house valve. In essence, switching off the whole of house valve (probable a Dome) for let's say 10-30 minutes ( every midnight) and waiting for the pressure to stay put (OK) or to decrease which means that there some small leaks or running toilets. Not sure if it will work or not but in shouldn't be difficult to test it.

@sburke781 awesome! Follow to the letter and it worked. However, I want to share a couple of tips to make it easier for other n00bs like me:

When you want to uncomment something on the grafana.ini file, semicolons must be removed as well. Also, look for the tile driver that @sburke781 on google because the one I found here did not work (the one iFrame). Maybe I did something wrong, but the one with the reference Tile Master tile driver work for me, and also the names of the attributes are different on the iFrame driver

The only step back I found that is when I access the dashboard after the second day of running, instead of the chart is showing me the login window of grafana and doesn't matter if I try to loggin it ask again for sing in.

1 Like

Great to hear you got this working @luis.gil, and thanks for the feedback.

I have updated the notes from my earlier post to include your tip around semi-colons for comments and updated the reference to the attribute name for the Tile Master device. I also took the opportunity to tweak some of the other notes / phrasing.

I haven't actually tried using the I-FRAME driver I mentioned to you a few days ago, but I would expect the process to be slightly different if using this, at least in terms of the attribute names used. If I get around to trying it I will make some notes back here on how to use it.

In terms of your issues with the login screen I can only think the settings haven't stayed in place following a restart or something else...? I know that after I upgraded Grafana a few months ago I needed to re-apply some of these settings, and I think I saw a similar issue to you. Perhaps check the ini file again?