Got Lutron integration working for dimmers, but not picos

I must be doing something silly...
I got my Lutron Caseta integration working well with the dimmers physically connected to the bulbs; but I'm failing to control my Picos.
In the integration report I have, for a pico:
"ID" : 9,
"Area" : {
"Name" : "Living Room"
"Name" : "Living Room Right",
"Buttons" : [<list of 5 buttons, 2 to 6>]

I created a fast pico device (I also tried the push/hold one, no difference), on device #9. I go into the device, and try to push button #1, but nothing happens (number of buttons is set to 5). I tried pressing any number 1 to 6, nothing happens. If I physically press the Pico buttons - or use the Lutron app, everything works fine.

What am I missing?

These will be automatically created, if you had to add one manually something's wrong with the integration report...

When you do this, do the pick button events appear on the live logging page?

Hey have you set up a app to use the buttons such as button controller or rule machine? I have a pico set up and am using the rule machine to set the button for use.

I haven't got to that point yet; I wanted to test things at the device level first - which, as mentioned, work well for the dimmers... If the device doesn't respond as expected, can't think how another app using it could work.

BTW, I'm running

Yes, I do see events when I press and release the physical buttons!
Not sure I understand what you mean with "these will be automatically created"... automatically as the result of which action? Do I need to include all the physical dimmers associated to a Pico to make this work?

Do I need to include all the physical dimmers associated to a Pico to make this work?, I tried that - no changes.

I re-read this, and I believe I misunderstood you; you are saying that the device should have been automatically created as the result of setting up the Lutron integration app. Yes, that's what I meant with "I created a fast pico device" - sorry for the confusion.

So, now we know that my device is receiving physical events from the pico remote, but I apparently I cannot send a command. Let me try @leeonestop suggestion.

No luck; it looks like Pico devices are able (meant?) to process incoming events, but not to push commands. I also see no activity in the Lutron Telnet device when a Pico button is pressed/released - while I see activity when I do the same for a dimmer.

Picos are meant as an input device so you press the physical button and then program what you want run as a result. It sounds like you see events when you press the physical button which is what youโ€™d expect. This doesnโ€™t seem to be what you are trying to do though. What is the workflow you are trying to accomplish?

Yes, I figured that's the case, given the observed behavior.
What I was trying to do is to have an application control lights directly through the Pico devices, rather than directly accessing the dimmers. I have a large room with many lights, which are controlled by 3 physical (hidden) dimmers; and I have one Pico (accessible to people) which controls the 3 physical dimmers. The right thing to do seemed to have the app control the Pico, and ignore the physical dimmers; but I guess that's not possible in the current integration.

Correct. The Pico Remotes simply generate 'button events' within Hubitat. They can only send data to Hubitat. Hubitat cannot send data to a Pico remote.

You can very easily create a Group of Lutron Switches/Dimmers by installing and using Hubitat's built-in "Groups and Scenes App". For each group of dimmers you create, a virtual 'Group' device will be created on your Hubitat hub. You can then use this single group device to control the lights in any automation your desire (e.g. Simple Lighting, Motion Lighting, Rule Machine, Hubitat Safety Monitor, etc...)

1 Like

Thanks @ogiewon; yes, I know how to do that in Hubitat; I was just trying to avoid duplicating the "grouping knowledge" in Hubitat, considering that that's already defined in the Pico association in Lutron. But it is what it is.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.