Google Home app is not showing some devices

I have a few devices (H801 RGB controllers are the main ones I notice this for) that will not connect to Google Home using the default Hubitat integration. Every time I am them to the allowed devices list of the integration and then open Google Home app it seems they are removed from the devices list.

I can repeat this "add to integration list" as many times as I like, but as soon as I open the Google home app they are not visible in the app and get deselected again.

If I change their names, change parameters....etc then it doesn't change the behaviour. It is very repeatable but I'm not sure what logging to show to help debug. Incidentally I have 4 of these devices and only 2 have a problem (the other two show up fine). I have even totally removed the Google home link and recreated it, but it didn't help (and was super annoying as every single device needed readding to my home and a room).

I can see there is another topic about some thermostats not being visible in Google Home (though mine are), I'm not sure if the problems are connected?


Thanks for the comment, however 2 out of 4 devices are showing fine in Google Home right now.... And before the upgrade 3 of them were showing, it's only when I tried to control them today (on/off control) that I noticed they had vanished (because the error message was unexpected).
Also has never been a problem when they were setup in ST, it's just a simple 'RGBWW bulb style device' connected through wi-fi

Do I need to give the community integration a go? Does anybody have any experience of that in comparison?
Thanks again

Ok.... so many hours of testing later, the lights get rejected by Google home if there is no 'level' stored as a 'Current States'.

The light responds to level commands, but because it had never been set/changed then the 'level' state was not created. Every time I removed and re-created the device, it was removing any level information that I might have stored through my testing. Once you set level to 100 it will then be accepted as a valid device by Google Home and can be controlled through it (even if you never actually use the level commands). Hence having a state variable set at some point during device creation is key!

You were part right @Eric.C.Miller! Thanks

1 Like

I never would have guessed that! Wow!

Open your logs in a browser tab. Then in a second tab, add the device to Google Home and click Done.

Now flip back to the tap with the log. Do you see this in the log?
The following devices are not supported by Google Home and will be removed from you device list: [Device name]

If so, it doesn't support the RGB controller. Look in your device details under Current States for the type of attributes the device has. That might be what's throwing Google Home off. In the case of Thermostat Controller, it was that Google Home was seeing a device that was both a thermostat and a switch and it doesn't know how to handle such a device, so it rejected it.

Sounds like this is a similar bug then.

Yes I spotted that log entry and that was how I worked out what was going on. Then did some debugging with what information(/state) was different between the devices that Google Home accepted and rejected.

1 Like

I just paired some new Sengled Element Color Plus bulbs and they rejected with the message The following devices are not supported by Google Home and will be removed from your device list:[ whatever name you chose]. It appears that there may be another setting causing the reject also. I had to either the hue or the color before it would accept it.

Advice I'd give to anyone having a RGB bulb rejection problem with the message shown above in their logs, would be to manually change all the settings in the device, then attempt to add it to Google Home again.
I'm not an expert, and don't play one on TV, but it's what worked for me.