Global variable errors


Got some more GV issues. They are new with the update.

These actions are called by wato.

Need to see more information than that.

Such as?

Logs, description of what's going on. Can't tell anything from what you've shown.

This has been working fine for a month, since major update where Global Variables were introduced.

I have an alarm system that I've integrated into HE (it's different to normal panels and doesnt integrate via HSM etc). It has four statuses (armed, off, away, arming). I have used WATO to monitor the status of the alarm system. The alarm system controls all my HE modes.
When alarm = armed, then mode = away etc.

Yesterday, these errors started appearing when the alarm status changed, and as far as I can tell, it's not WATO, because the error is coming from the RM3.0 rule that is called by WATO when the alarm status changes.

This is the WATO

This is the rule called by the WATO, that has the error

For some of the status changes, the mode DOES change (when WATO calls an action, not a rule). But when WATO calls a rule, the mode does not change, that is the rule fails to run. In both cases, rules and actions, there is an error in the logs.

Here are the errors in the logs. I turned on the alarm to stay, which successfully changed the HE mode to night. But errrors.

Does this work if you just click on Run These Actions in the RM UI?

Yes and no, and no.

Yes, like above, actions work and the mode changes. But no, the rules and triggerred rules fail.

And No, in all cases there are different errors to previously listed above. These errors are bypassing WATO.

OK, you've only showed the one rule that is an Action, so I have no idea what you're talking about.

These are all RM3.0 rules. I am simply hitting "run these actions" or "run this trigger"

This trigger did change the mode, but produced an error.

Error here:

This trigger did not change the mode, and produced the error (the error comes from this rule).

This action did change the mode, and produced an error

If you want me to find out what's going on I need you to simplify the information you are showing. In any rule that is throwing an error, turn on all logging, so we can see where in the process the error is arising. The error messages themselves carry no useful information.

I am not able to reproduce any of these errors, making rules similar to yours. I have tried Triggered Rules, Triggers, and Actions, and run them from the UI, and run them from other rules, and have them setting mode. None of these fail.

So pick one of your rules, turn on logging, and let's see where it fails.

I appreciate the time and effort you are going to with GV's.

I've turned on logging fully, and I dont get much more data in the logs.

all logging is turned on.

OK, I'll create a rule just like that one and see if I can get the error. The logs do show better where it is happening.

Why are you using a Triggered Rule when all you need is a simple Trigger?

Because, when I created the rule, I was not sure what "run rule" did. Remember this rule is called by WATO when the alarm changes to OFF, and at the time, I thought I needed the "true" side for the "run rule". I read a post somewhere that @bangali asked about run rules running the true side of a triggered rule. I've since realised that actions would do.

I just tried one like that, with no problem. I have a string variable, triggered from it becoming "off", and it works without error.

Are dashes OK in GV's? Also, I was on 118, and am upgrading now to 120


Yes. I just tried the same thing with a variable with a - in it. Triggered rule just like yours, no error.

Have tried deleting these rules and recreating them? Or just one of them...

1 Like

No, I'll delete and recreate a rule now.

No error on rule recreation. Thanks for the help. Sorry about confusion.

These things happen sometimes, and it's usually not clear why. Good rule of thumb is that if something stops working, odds are good that throwing it out and recreating it will work.