Getting more out of notifications

What does the Events tab look like?

Are you on v2.0.8? notify1 was removed in 2021 IIRC

I downloaded the driver at the beginning of this post. Is there something more recent?

/*

  • Notify Tile Device
  • Licensed Virtual the Apache License, Version 2.0 (the "License"); you may not use this file except
  • in compliance with the License. You may obtain a copy of the License at:
  •  http://www.apache.org/licenses/LICENSE-2.0
    
  • Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
  • on an "AS IS" BASIS, WIyTHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
  • for the specific language governing permissions and limitations under the License.
  • Change History:
  • Date Who What

  • 2021-01-06 thebearmay Original version 0.1.0
  • 2021-01-07 thebearmay Fix condition causing a loss notifications if they come in rapidly
  • 2021-01-07 thebearmay Add alternative date format
  • 2021-01-07 thebearmay Add last5H for horizontal display
  • 2021-01-07 thebearmay Add leading date option
  • 2021-01-22 thebearmay Add a span tag and id to allow custom CSS on the text

*/

Forgot that I had posted a copy of the code back then (will update that to a link). The current version is at https://raw.githubusercontent.com/thebearmay/hubitat/main/notifyTile.groovy or can be pulled down using HPM.

That should explain the issue. I’ll check in a bit. By the way, for some reason, I could not find the code on GitHub or HPM

Installed the new driver and created a brand new device and…. I still have the exact same issue when using from Webcore…any clues?

What do you have the message count set to?

Set at 5. Works fine with RM, but only update the last entry in WebCore.

RM script

WebCore script

RM and webCoRE are taking two different paths with the way you have them set up. To mimic the RM rule, set the Notification Tile as a Notification Device in webCoRE settings, and then use Location - Send Push Notification to send your message.

The Notification Tile is set as a notification device. If I use a send Push notification , the message will be sent to all my notification devices (phones, etc). My understanding is that only the send device motivation allows to target an individual device.

Can you try turning on the debug and run a couple of notifications through it, and then posting the logs?

Not sure if it's the issue, but let's change line 113 to

		if (state?.lastLimit.toInteger()>settings?.msgLimit.toInteger())

Unfortunately, I still get the same error after updating line 113…

I thought that would be the case, but it should eliminate the error that was being reported there. Logs look like things are working correctly. Can you update the code from:

https://raw.githubusercontent.com/thebearmay/hubitat/main/development/notifyTileDbg.groovy

turn on debug, run a couple of notifications through it, and then post the logs again? (I've added a few more debug lines)

Here you go. I commented line 208 as there was a syntax error I was not able figure out.

Can you post the device page including the preferences, I’ve not been able to duplicate your experience so time for a new instance on my dev hub.

Here you go

Found a few things that were odd with a new install. If you pull down the new code, and then go into the device and hit Configure, you should be good

Download the Hubitat app