Geofence not working in 1.6.7

The toughest issues to resolve are those issues that don't affect everyone or cannot be replicated internally. Geofence is one of those features. Our engineers are actively investigating and working on bug fixes, but I do not have an ETA when they will be released.

The mobile app doesn't require a subscription of any kind, so users with or without the add-on services have identical experience, whether good or poor.

Thank you for your patience.

2 Likes

The beta version seems to have fixed the issue, just push that version out to everyone while you're trying to figure the cause of the issue

4 Likes

"Reports of my exit are greatly exaggerated."

I'm in the Android beta, and it has started repeatedly reporting my exit even though I'm a mile away from the fence. Hourly, maybe even more frequently for a couple days it seems. Let me know if any logs would help. I'm assuming this is a sign of progress on android.

Any way to get an ios beta?

Hasn't fixed the issue for me.. the geo fence is still horribly unreliable. I wouldnt have anything critical dependant on it. I´ve just found other options which I have found to be more accurite and reliable.

For what it's worth it seems like 1.6.8 build 128 works well. If anybody is having issues with it, try uninstalling it and reinstalling it, that worked for me after it stopped updating when clearing cache and data didn't.

1 Like

That's the build I'm on and it has worked flawlessly on Android 11 and 12 on a One Plus 9 and Android 11 on a Galaxy A32.

1 Like

@BrenenP & @scunny - what settings are you using? It's completely unreliable for me with a pixel 5a (Android 12) and pixel 6 pro (Android 12).

Delete the device in Hubitat, uninstall the app on Android, install 1.6.8 build 128, login and register the device. Test it by looking at current states and moving the radius or map marker to see if it updates. Make sure battery settings are "unrestricted" and "allow all the time" is selected for location permissions.

2 Likes

In my case on both versions of Android I have location allowed all the time and on the battery Allow background activity. I've never had to go through the moving the map marker gyrations.

1 Like

What about on this screen?

All off, no delay.

Im on 1.6.8 build 128. The geofence isn't working sny better. For example in the screen shot below (takrn 2 minutes ago) I am the top left.I haven't been home for an hour. My wife top right, hasn't been home since Sunday morning.

I completely agree. Not working reliably at all for me either.

From reading other threads here on the forum, it seems like geofencing works properly in version 1.6.3. I haven't had a chance to test this yet.

Try the steps I listed. I was having issues with it not reporting as well until I uninstalled it and set it up again. Does the map say inside or outside? What does it say in logs? Does it change if you move radius or pin? You can manually test it just by moving the pin to where you are.

@jonathan.lorber did you try what I posted? All of my advanced settings are off with no delay, but I haven't tested those.

1 Like

It's reporting, but just not consistently.

1 Like

I've done that several times. It worked for a few days then stopped.

Maps says outside, log header says outside, but i never see the event of leaving. And it's not telling the hub im out of the geofence.

Sorta. Moved the pin to where I (and my wife) were. When I moved the pin back it updated me as not home but not her.

At this point the geofence is a novelty. I would never have any critical automations dependant on it. If you have to keep going in and moving the pin to tell it you've left, what's the point?

Edit.
It's now working at the moment. Past experience with this tells me it will stop working in a few days.

Unless there is some super secret beta,1. 6.8 build 128 is the current beta. Last update was 1/6/2022.

1.6.8 128 is the current beta.

Sorry I didn't make it clearer in my previous comment that going BACK to the 1.6.3 version was a supposed fix.

That wasn't my point, I was telling you to do that to troubleshoot. You should see it update in the app and on the hub as you move the pin/radius. If it's updating then it isn't the issue I was having before. At that point you should double check location permissions (all the time is required) and battery optimization (unrestricted is required).

If it doesn't update when you move the pin, like if it seems like the app isn't talking to the hub, that's when you should uninstall and reinstall the app.

1.6.8 build 128 has been flawless for me since I've done this troubleshooting. I've been testing several apps and hubitat / smartthings were the most reliable.


1 Like

I just upgraded to UI 4.1 on a Samsung phone, and it has the option to exclude certain apps from memory optimization, in addition to those locations specified in this thread (battery optimization, where I already had Hubitat included).

I've just added Hubitat to the list of memory optimization, and I'll see if it makes a difference.

Download the Hubitat app