GE ZWave Plus Plugin Lamp Dimmer

I have two of these devices, they paired as Generic Z-Wave Smart Dimmer. They are not showing any digital events using On, Off, or SetLevel until a Refresh is done. I tried the Generic Z-Wave Dimmer and it shows some changes but the level and on/off status is rarely correct without a refresh. I think the SmartThings driver for these did basically a refresh a few seconds after an operation.

  • deviceType: 20548
  • inClusters: 0x5E,0x56,0x86,0x72,0x5A,0x85,0x59,0x73,0x26,0x27,0x70,0x2C,0x2B,0x7A
  • deviceId: 12344
  • MSR: 0063-5044-3038
  • manufacturer: Jasco Products

I believe this is one of the devices that does require a refresh to be configured. I haven't done this so I will stand down and let others provide you the information but I think there is a solution.

Z wave plus devices are supposed to update as soon as they reach their commanded level. However, I was unable to get my GE Z wave plus device to work with the Generic Smart Z wave dimmer driver. I had to use the Generic driver for non-plus devices. Otherwise, it would not report back any changes made in software until after a refresh. No one has been able to tell me why yet. My fingerprint says it's a plus device. So, try the generic driver and see if that works. Also, i have the regular z wave model and it doesn't show the correct level until a second after it actually reaches it. So, you might have to wait a second in HE.

I see the exact same thing with GE ZWave Plus switches and plugin dimmer modules. Both detect and use the "smart" device type when paired, but neither refresh the level when set programmatically (RM, Cobra's One to Many, etc) without a refresh.

Using the generic (non smart) device type does make the levels refresh, but with a 1-2 second delay (as @Ryan780 already mentioned). Although if I turn it off programatically the OFF status doesn't seem to update. This is very disappointing.

Here is what I see when I turn off my overhead light. The other dimmer does turn off too (from One to Many app), but the status still shows as on, with a weird level%. So the dashblard is completely useless for me, as the status and levels are all wrong.

dev:762018-12-09 08:36:31.443 am infoLiving Room Light Dimmer was set to 79% [digital]

dev:772018-12-09 08:36:31.055 am infoLiving Room Overhead Light Dimmer was turned off [digital]

Works correctly on other hubs (ST, HomeSeer). I will just say it has been a very frustrating first week with Hubitat. I have so many things that work worse than before. :frowning: I'm sure it will get there eventually, though.

1 Like

The Smart Driver was just updated so it should be working correctly now. It is for my Z wave plus modules.

Unless it was updated since I posted this morning, it definitely doesn't work on any of my GE ZW+ dimmers with digital commands... I have tried it on 3 different ones - status does not update if level is changed digitally.

I tested w/GE 14280 and GE 14294 devices.

But it does change if you turn it on or off digitally? Have you hit the "configure " button on the edit device page?

It functions correctly, as in it will dim and turn on/off digitally (i.e. when executing commands form the dashboard).

I don't think I have ever hit 'configure' on the edit device page. Not sure why I would know to do that? This is a new install (~4 days old), so started out on

I'll go try that, though...

When you install a new device you almost always have to hit that in order for it to finish configuration of the device (don't ask me why, someone with more knowledge will have to answer that. I just know it fixes most of your initial problems).

I understand that when you change levels digitally that isn't being reflected in HE. But if you turn the device off digitally, does that reflect in HE. Also, if you set the level within HE on the device edit page, does it reflect that change correctly (not with your one to many app).

This works and status is updated:

  1. On digitally
  2. Off digitally
  3. Level digitally
  4. On via One to Many app
  5. Off via One to Many app

What does not work:

  1. Level changed via One to Many app

Maybe it is an app problem... Although I don't see exactly how since the light DOES change brightness... I'll try to do something similar in RM and see if that does something similar.

EDIT: I can't replicate in RM... Maybe this is an app issue after all. I already posted in Cobra's One to Many thread, I guess I'll see what he says.

Okay...can't help you there. Have you looked at using the integrated Groups app? You can group lights together and a virtual group device is created. When you change that device all the devices within the app mirror it. Might want to look at using that instead.