GE Zigbee plug-in dimmer won’t pair?

I recently unpaired my GE zigbee plug-in dimmer from my SmartThings hub (model # 45853GE, aka ZB4101 on the jasco product page). I’m running the most recent firmware on my hubitat hub, v. 710.

Following the manual reset procedure in the device’s user manual, I simply can’t get the hubitat hub to find it. Doesn’t matter how close I bring the device to the hub.

The instructions say to press the button on the device while plugging it in to reset it. The device blinks as it should while in pairing mode. I’m able to pair it back up with my ST hub easily.

Has anyone gotten this device to pair with your hubitat hub? If so, did you do some other button-press procedure on the device?

Did you exclude the device from SmartThings first?

It’s a zigbee device, so there’s no actual exclusion like with z-wave. But yes I removed the device from ST before trying to pair it with hubitat. According to the manual, that should have been sufficient to pair it with a new zigbee coordinator.

And for good measure, I’ve been trying to physically reset it while attempting to pair with hubitat, as I described.

All to no effect, so far.

Here’s a link to the manual:

I can tell you it sometimes takes 5 minutes or more for some Zigbee devices to pair. Just be patient.

I have noticed that too, with other devices.

This device will time out if it doesn’t pair after a few minutes. According to the manual, it allows for one additional attempt at pairing by pushing the button on the device, which will then time out again after another few minutes if pairing still does not occur.

Then I start over by unplugging and plugging it back in with the button pushed. Bupkis.

When I re-pair it with the ST hub, it pairs immediately. So it could be somehow refusing to forget the ST zigbee coordinator. But if following the procedure in the manual doesn’t do it, I’m not sure what does.

Just to confirm, you are unplugging, holding down the button, plugging back in and then releasing the button within 2 seconds? If you hold the button it won’t reset.

Correct, I am pushing it, not holding it. As per the manual’s instructions.

Try completely disabling the SmartThings hub first. Remove batteries and power cord, and try again. You may also need to change the ZigBee channel. Some devices are finicky about that. Are your SmartThings, router and Hubitat frequencies overlapping? Check the troubleshooting wiki for an overlap map.

Having paired well over my fair share of zigbee devices on my hubitat production (> 50 zigbee devices) and isolated development hubs, if it doesn’t get to the initial pairing (where it shows the 64 bit address) within 30 seconds, don’t bother continuing. For me “don’t bother” in production is always insufficient repeater coverage.
As I’ve mentioned several times in various threads, your best bet is to pair in place, if it won’t pair in place, the device certainly isn’t going to work in place for very long, if at all.

The 30 second rule obviously applies to devices that we know have paired to hubitat before.

For the most part I’ve had reasonable success pairing in place with my zigbee devices.

With this one, even bringing it within a few inches of the hub doesn’t seem to help.

@marktheknife Did you ever get the ZB4101 to pair? I could get a couple of these pretty cheap but I don't want to invest the time if they won't work. I could not find other posts about this model - I have the z-wave version and l like those. If you did get it working, did it also report power/energy?

I bought several of these for $5-$10 (Lowe's) each and they pair without issue and have there own driver in HE with power reporting.

Thanks Ken, is that the "GE Zigbee Switch" driver? I didn't know if that was just for the in-wall unit or lamp module also. Do you find the power reporting to be OK?

I have a couple switches and a couple dimmers and use the GE zigbee switch or dimmer drivers with them. Power reporting works well for me.

I bought quite a few of the in-wall dimmers and switches as well and the same driver seems to work well for both. I replaced some zwave plus devices that I wanted faster response from and haven’t been disappointed.

Nope, after a certain point it simply wasn’t worth troubleshooting much further.

If I had to guess, maybe changing the zigbee channel on the hub could have made a difference. But that’s a PITA because every other zigbee device would have a minor freakout trying to find the hub again, and I don’t want to walk around the house popping batteries in and out to get things back to status quo faster.

Since getting more into hubitat I quickly went with as many Lutron Caseta devices as possible, since the integration with hubitat is so great and I don’t have neutral wires in my switch boxes anyway.

I don’t miss that zigbee plug-in dimmer at all.

I’ve used mine on channel 15, 19, 20, 24, and 25. I didn’t notice any issues with them on any channel. It’s been a long time since you first posted this, and it may just be that something has been fixed on HE since then. The only zigbee devices I have that don’t change channels nicely without resetting are my Hue dimmers. They are a PITA.

I also had issues trying to pair this device on HE. I bought two of them a few months ago and after neither would pair, I tried pairing them to my ST hub and both paired instantly without issue. For lack of anything else to try (I have no indication of any mesh issues), I temporarily changed my HE hub's Zigbee channel (it was on 18) to match that of my ST hub, which was 24. Voila.. both plugs paired immediately to HE. I quickly changed the HE hub's channel back to channel 18 (I too wanted to avoid the freakout scenario). Within a couple of minutes both Zigbee plugs also re-scanned/rejoined on channel 18; they have continued to work fine since. Still not sure what is the root cause of this particular issue..

1 Like

I know this is an old thread, but I am hoping earlier posters to this may have updated to the latest firmware and are still using the system.

I just bit the bullet and ordered a Jasco 45853 from Amazon. I don't need the 2 outlets on it, but needed the form factor, zigbee repeater, and power monitoring.

I am wondering, how is the best way to configure this to get what I want out of it? What driver should I be using or does it auto detect when pairing and get set up correctly straight away now?

I am presently using a C7 hub running firmware 2.2.7.122

Thanks.

I have several of these and they paired easily and have been reliable. I had them before the GE specific driver was rolled out, but I would imagine that it would automatically select that. It seems to be an okay repeater, as long as you don’t have picky devices. My Lightify 4-button switches and Hue dimmers didn’t seem to behave with them, but no issues with bulbs and other switches/dimmers.

1 Like

Download the Hubitat app