GE Jasco switches not responding to dashboard commands


#1

Hi - I just got my HE yesterday after struggling with my WINK going offline daily. I successfully paired my 4 GE JASCO z-wave switches (not z-wave plus - model 12722) to HE and set up some rules. The Rules seem to be working great. I created a dashboard and ran into 2 issues - first issue solved by adding a "refresh" rule.
The second issue is that for some reason the switches do not respond to commands sent by the dashboard. I get a "sending..." status and it never changes. Also, the light I want to turn off does not turn off. I have no idea what I'm doing wrong.


#2

You need to add the Z-Wave Poller app to them to poll them for updates.

You can remove dashboard from the equation and see if the state updates in the device details in the Hub Web UI.


#3

Correction, dimmer 12339 and same problem, non responsive from dashboard, will try polling..workaround.

Update-So polling allowed these to work from device page, but always logs all actions as physical, and the dashboard is still unresponsive
Mike- are these junk or is a driver tweak able to help?
I guess I know why the switch was so cheap.


#4

I removed the "refresh" rule and added the 4 switches to the Z-Wave Poller app. I'm not sure of the frequency of the polling, but the switches are not showing their correct state even in the device details in the Hub Web UI. I set up a quick "simple lighting" rule to turn on 2 lights and then turn them off 3 minutes later. The rule worked and turned the lights on and off right on time, but the device details in the Hub Web UI did not show them as on when they were on.


#5

When trying to sort out these sorts of issues, you always need to start with the driver-device combination, by that I mean from the driver details page do digital and physical commands work properly?
Can you control the device from the driver page?
Do current states update correctly for both digital and physical actions?
The older ge devices can have issues updating physical actions, in these cases you will need to implement a polling rule.
The older ge devices should update current states when commanded from the driver page, if they don't then the issue is with the device itself, or a mesh issue, or possibly the wrong driver selected if the device paired as device.

Polling is not the solution if you can't control the device from the driver page.


#6

I can control the switch from the driver page.

The current state does not update for either physical or digital actions.

I tried my own Polling rule with inconsistent results. I removed that polling rule and am now using the Z-Wave Poller app.


#7

What specific device?, what driver did it pair with, and what driver are you now using with it.


#8

GE JASCO z-wave switches - model 12722. They paired with the Generic Z-Wave Switch driver. I have not changed the driver.

Interesting note - I logged events while my simple lighting rule ran. All the lights turned on and off as they should, but only 1 device event logged.


#9

Ok, when you click refresh in the driver, does it update correctly?, and does it always refresh correctly?


#10

Yes. It seems to update correctly when I click refresh in the driver. I can also control it from the driver.


#11

It's possible that we aren't waiting long enough in the driver from when we send the command to when we ask the device to report it's state.
Currently we wait 300ms, I can try to bump this up, but suspect this isn't going to help.
You've done a zwave repair?


#12

I can try a zwave repair. I'll let you know what happens.

One thing to note is that even when I did a "Rule Machine" rule to refresh these switches every 11 seconds, the results were very inconsistent. Once in a while they all reported, but most often 1 or none reported and the others remained silent.


#13

Ok, this leads me to beleive that the device is able to receive commands from the hub , but the hub isn't able to receive commands from the device.
Could be a router issue, as not enough of them, or a bad route that should be sorted by the repair.
We have a doc in our wiki on how to build a solid mesh, I would review that if you haven't already...


#14

I did a z-wave repair and then tried to turn on and off from the device page. I can control them, but the current status does not update. Doing a refresh from the device page did not change the status either.

I read the wiki on building a solid mesh several times before I booted up the HE for the first time yesterday. I was careful to exclude the 4 devices I have using the WINK - all GE JASCO z-wave switches (model 12722). These switches have no way to do a factory reset as far as I can tell. I started with the closest switch and worked my way away from the hub. The first 2 paired right away. The last two were a pain to pair with the HE. They also would not exclude using the HE. I had to plug the wink back in and exclude them using the wink hub. Just to make sure they were indeed excluded, I paired hem with the wink and then excluded them. They disappeared from the wink. I was finally able to pair them with HE when I used a longer ethernet cord to get HE close to the last two switches. I'd leave the HE there, but I'm sure my wife would not appreciate having the hub sitting on a chair in the middle of the kitchen!!


#15

Yeah, if you can't pair them in place, they will not work in place, you will need another switch/dimmer/repeater somewhere between the two that you were having trouble with and the hub.


#16

More testing, it seems regular Z-Wave devices and the dashboard don't work well without polling, at least with my devices. After adding polling to my GE dimmer and aspire rf9540 switches, I can control them from the dashboard, albeit slowly, but that's fine for me


#17

I have about 30 of these switches, and in my experience, they would not exclude or pair at all beyond a certain range from the HE hub. To get them to pair, I had to take the HE hub very close to the switch (using a very long network cable and a mobile battery brick with USB output and a micro-usb cable), and then exclude and pair it. After that, they would work Ok. My theory is that the Z-wave chip severely limits its range when excluding or pairing so that it does not end up excluding or pairing unintended devices, since essentially anything that is activated (usually by pressing a button) during the exclusion or pairing period will be excluded or paired. (WARNING: Be sure to shutdown the HE hub properly before switching to the battery or back to the wall-adapter so that you don't lose some of the configuration.)


#18

I have about 12 GE Z-Wave switches and I have one setup to control a SmartPlug when the GE switch is turned on/off so they go on/off together, however I've noticed the same issue with that light, sometimes it would detect the change fairly quickly and other times I would notice the SmartPlug left on 20 minutes after turning off the switch and I'd check the switch device and it would show it was on until I clicked refresh. I noticed this with another light last night since I looked at my dashboard and both it and the device itself showed my kitchen light on but I was pretty sure my wife would have turned it off so I clicked refresh on the device and it switched to off. I added both lights to the polling app but I'm wondering how frequently that happens and I haven't manually tried the poll option when a switch was showing the incorrect state. If I turn on/off the Sewing room device programmatically the Smartplug turns on/off within a second or so, it's only when I use the physical switch that it can take anywhere from a few seconds to not happening in the time I'm willing to pay attention to it.


#19

I was limited by the length of Ethernet cable I had laying around so I only got within 20 feet of the two switches in question. That seemed to do the trick. This post had more to do with the hub and the dashboard not knowing the current state - as well as the dashboard not being able to control the switch.


#20

Over the past 2 days my automations seem to be working flawlessly. HOWEVER - HE has no idea if my switches are on or off. Clicking the "Refresh" button on the device page has no effect. The state does not change to the correct state. Clicking the "Poll" button on the device page also has no effect. Clicking "ON" or "OFF" on the device page works just fine, but that does not change the state either. I have "Z-Wave Poller" running for the 4 GE JASCO model 12722 switches that I have. These are the only devices I have at this time. Apparently the Z-Wave Poller APP has no effect on these switches. Thoughts on what I should do to get the correct state reflected in HE?