GE/Jasco 240v direct wire switch

I have two GE/Jasco 240v 40 amp direct wire switches (Model # 14285) that I purchased to control a hot water heater and a well pump. These switches are Z-Wave Plus type devices which require you to press a button to enter pairing mode. After multiple attempts I was finally able to pair them. The trick proved to be pressing the pairing button on the GE switch once, then told Hubitat to search for devices, then pressed the pairing button on the switch a second time. Bingo, they paired. Hoping someone develops a driver for these switches at some point. For now, I configured them as a Generic Z-Wave switch and that lets me turn them on and off remotely


I’ve got this too but really wishing the HE driver supported energy monitoring like the ST native driver. I haven’t found any generic zwave metering drivers in HE.

Any ideas/suggestions from the devs? @mike.maxwell I’d be willing to reconnect to ST to debug if that would be helpful.


Are you sure that's the same device as the OP? I would have expected the 0x5e cluster on a 14285 since it is z-wave plus....

In any case, on the surface (assuming GE didn't do something really wacky as they do sometimes), that looks like it would be a simple driver to make as a user driver. The issue will be that very few people own one of these, and it isn't any fun writing drivers without a device to work off of - although it can be done with some trial/error and logs from someone that has the device.

I’d be happy to try writing (editing) a driver. Was hoping that a generic “zwave metering outlet” might fit the bill as I believe that’s what I was using on ST. Do you have any links to these types of generic drivers that would give me a starting point? I wish the ST drivers were public :slight_smile:

Would probably be easier to just start from scratch since it is just a switch + meter capability.

Let me see if I can find one that's close. I have lots of switch ones, that part is really easy. I need to find a driver that incorporates meter correctly.

1 Like

I have the same device, I use 3 of them with some automation routines to control my Pool, and Spa. This is currently my only device which won't pair with Hubitat. Don't need monitoring, just simple control would be adequate, but none of the built in drivers (including the OP's mentioned "Generic Z-Wave Switch") are working on my units.

They pair fine in ST and modulate fine. Hubitat will see them as "Device" but won't allow me to control them. Any hope for a quick / custom driver? These are 40 amp outdoor switches that cost $200/ea.

1 Like

My only issue is I have to manually refresh to get the power info (ie it doesn't send it to the driver).

Tried using this driver, but it still doesn't work. I can add the device (added as device), install your driver, select your driver. Now I can see the power info, but I can't turn the switch on or off remotely.

I don't even care about power usage, I just want to control my pool pumps on a schedule, and modulate them with a trigger (Spa routine). Since transitioning to hubitat I'm now forced to run "two hubs" over this issue, it's rather frustrating. The distance from the outdoor switches to my Z-Wave hub is significant, and without the benefits of the Z-Wave peer to peer network they are now intermittent. I'd pay to fix this issue.

Note, the GE / Jasco switches have native driver support, and work flawlessly, using SmartThings.

Went to add images of my switches to this reply, but Hubitat is telling me I'm not allowed to put images in a post.

1 Like

Data * deviceType: 20292

  • inClusters: 0x5E,0x25,0x85,0x59,0x5B,0x70,0x2C,0x2B,0x32,0x55,0x86,0x72,0x5A,0x73,0x9F,0x6C,0x7A
  • deviceId: 12338
  • manufacturer: 99

Looks like I have an older model.

  • deviceType: 20292
  • inClusters: 0x25,0x27,0x86,0x72,0x32
  • deviceId: 12337
  • MSR: 0063-4F44-3031
  • manufacturer: 99

The ON/OFF should work with the generic zwave smart switch driver - that device just takes a normal on/off command like any other switch (per the maufacturer's command class listing).

Are you sure you aren't having zwave mesh issues / weak zwave mesh? And that the on/off simply isn't making it to the device? I've found, anecdotally, that the radio in the HE hubs are much weaker/less sensitive than the ST hub - making strategically placed repeaters a necessity on HE, when they weren't needed at all in ST...

1 Like

I doubt its reception, the device is still seen (but not recognized) in Hubitat, and the regular GE/Jasco switches which control pool lights, pool bubbler, and the heater relay, all modulate fine. These devices are all within 2-3 feet of each other, 50' from the next cluster of Z-Wave components.

That the device would have lower Z-wave reception than a simple toggle switch, even with its large antenna mast, seems unlikely. Also, it would get Z-Wave signal from the clustered devices 2-3 feet away, which modulate fine.

Using the "Generic Z-Wave Smart Switch Driver" does nothing, the device is non-functional with this driver.

EDIT: Never mind, I see you posted logs ion another thread.

Actually, this driver is working. I posted the debug log in another thread and realized I had the switch itself in "physical off" mode.

1 Like