GE/Jasco 2 button remote

I purchased a GE/Jasco 2 button remote without looking at Hubitat's Compatibly list prior to purchase. I assumed it would add to the hub without issue however I am not able to get it to add. Has anyone been able to successfully add this remote to Hubitat or does anyone at Hubitat have plans being able to support this remote?

These wont work, ever. They arent designed to report their changes to a hub, they were designed to control another zwave device directly.

1 Like

Thanks Mike!!!

Do you recommend any specific z-wave remotes? I have a Innovelli LZW36 (Light + Fan) Switch. Previously we had a small remote that we left on the end table that would we would use to turn the light / fan on/off. Now that we have the LZW36 my wife who doesn't like to use her phone to control the fan/light would like the ability to toggle on/off the light/fan.

Not Mike, but...does it have to be Z-Wave? There are a couple Zigbee options that might work (Hue Dimmer or Eria Remote come to mind; not a huge fan of the latter but it might not be bad for occasional fan control). There's also the SmartThings Button if you don't care that it doesn't look like a switch/dimmer. Along those lines, there are also a few Z-Wave remotes that might work (Hank buttons, Fibaro button, or Aeon remotes),

My favorite remotes by far are Lutron Picos, but if you're not already using Lutron, there's a bit of an entry cost for a Smart Bridge Pro (or Main Repeater). But if you think you'll need more than a few, consider pricing ir out--Picos are so cheap you'll probably balance in favor eventually.

EDIT - I should mention that since the LZW36-SN you have is also Z-Wave, you could probably use it with Association as GE intended (assuming you don't need anything logic from the hub), but I can't help with that.

1 Like

Mike, I am not doubting you, but it is really weird that all their literature specifically says this: (emphasis mine) about this button.

This versatile remote communicates with your hub to activate up to 6 unique, lighting scenes. Once the remote is connected to your existing network...

There also seems to be two similar devices, a scene remote and hub remote.

The Scene Remotes are apparently P/N 34176 I think this is the one you tried previously, and didn't work. And I can see why with the lack of Command Classes

And the button in this thread is referencing the different 37792 / ZW5307 as Jasco calls it Hub Remote. This looks to be a new device.

Compare the Zwave alliance document in the first post, for the Hub remote to this one here for the Scene Remote Z-Wave Protocol Implementation Conformance Statement

The Hub remote 37792 has Central Scene V3, Powerlevel, and a bunch of other stuff that the 34176 is lacking on the Command Classes section of the conformance statement.

TLDR: I think we have two different but very similarly labeled and appearing devices.

Edit to say, doesn't matter personally to me if it works or not, just curious about the part number differences and the conformance statement differences.

The units I purchased, and I purchased all three were labeled scene remotes.
The device in the posted link would work, whenever it becomes available...

But at 45 to 50 bucks a pop?, that's just stupid...

Agree. Compared to the very similar looking and much cheaper $15 Pico, you can pay for a Lutron Bridge with the savings from just about 3 of these.

When you state the "device in the posted link would work" are you referring to the remote that I purchased or a different remote? If you are referring to the remote I purchased I can assure you that I do in fact have the remote referenced above and it is listed as a hub controller not a scene controller. Regardless of how much I spent on it, if there is a chance that it may be supported I would rather keep it and wait versus sending it back.


It should work, the one you posted, we don't have a driver for it and I don't have the device to run any tests with it.
You can try the generic zwave button controller, or the generic central scene switch.
Nether is going to be a perfect fit though.

What's interesting is that it doesn't even find the device when I put both devices into "inclusion" mode. I'm probably doing something wrong but I am glad to hear that you think it may work. I'll have to try to add it again to see if i can get it to connect.

Just to keep everyone updated. I was able to finally get the button controller to pair with my Hubitat hub. Once added I set the driver to the Generic Z-Wave Button Controller. From there I used Rule Machine to setup what I want each button to do. FYI I can configure both pushed and double press for each button.


I bought an Jasco "Portable Wireless Solo Scene Remote" device (on clearance at Jasco's website). Like Charles, I just assumed these would work with Hubitat.

I've managed to get 1 paired to Hubitat through the normal Z-Wave inclusion flow. However, I'm not seeing any events in the Hub. I tried the "Generic Z-Wave Button Controller" (like Charles recommends above). I also tried "Generic Z-Wave CentralScene Switch" and "Generic Z-Wave CentralScene Dimmer".

No matter what I try, though, I'm not seeing any events (e.g. button press) show up in the event history for this device.

@charles: can you please talk through a bit more on how you got yours working?

Mine is Jasco model 34172 which I think is the same as the one you have. My Jasco instructions warn that pairing must complete within 20 seconds, so I wonder if maybe Hubitat's inclusion routine isn't fast enough?

Hey @eric17. I'm not at home right now but I will look back at my notes in the morning and will reply tomorrow. If my memory serves me correctly I remember having issues getting the remote to pair at first however around that same time there was a firmware update for Hubitat and after I applied the update and the hub restarted I was then able to successfully add the remote. Before you try adding the remote to Hubitat make sure you factory reset the remote (I believe the steps to reset the remote are in the instructions that came with the remote). Once added I used the "Generic Z-Wave Button Controller" and could see the button presses in the live logs. Again, I will look through my notes in the morning and will add any additional details I may find.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.