GE 40A Switch Energy monitor

please could someone recommend a driver for the GE 40A switch to provide energy metering function?
With Smartthings it worked great, but with Hubitat I just can turn in on/off but don't receive the Watt-values.

(this one:

)

There is a driver port from SmartThings called "Zwave Metering Switch". Honestly, something like this driver should be built in to Hubitat by now as it's a common requirement. Here is a link:
https://raw.githubusercontent.com/bdwilson/hubitat/master/Drivers/zwave-metering-switch.groovy

this driver works for turning on/off but does not deliver information about energy consumption with my GE 40A switches :frowning:

I have the same GE switch and I am using the generic Zwave driver. As far as I know there is not a driver that makes use of all the features of this switch for Hubitat. You may be able to edit the driver suggested above by adding the GE switches finger print. I don't know if that will do anything for you but I notice that it did not contain the GE fingerprint.

This what I see on my GE 40 amp switch (currently running my pool pump):
image
There are settings to turn on energy monitoring which will need to be done through the Basic ZWave Tool driver:


Oddly, these settings are not in the documentation which comes from the product, you have to look them up here:
https://products.z-wavealliance.org/products/2939

my GE Switches now report power data. :slight_smile: But they refresh only when I submit a zwave-ping. :frowning:

ConfigVal2 is 2 and configVal3 is 5. So I tried to change Val2 to 1 as suggested in your posting but it does not have an effect.

What I did:

  1. Installed the "Basic Z-wave tool" driver.
  2. changed the Device Type of the GE Switch to "Basic Z-Wave tool"
  3. in the SetParamenter fields I entered parameter Number: "2" size: "1" value: "1"
  4. I pushed "Save Device" below
  5. I changed back to "Z-Wave Metering Switch"

problem: configVal2 is still on "2"

Where is my mistake?

The "setParameter" label above the parameter fields is a button. In order to send the parameters, you have to click it. It's not obvious, and I made this very error just yesterday.

I've been looking for an excuse to buy one of these.. We will have an official driver soon..

4 Likes

Setup a rule to refresh it every 5 mins if is powered on. That’s what my pool heater logic does.

It's not necessary to force a refresh if the parameters are set up directly. Once the refresh is set to five minutes, the device will report power (instantaneous wattage draw) or energy (cumulative power usage since last reset) on a 5 minute interval if either or both has changed:

thank you for the hint! :slight_smile:

With two from three GE 40A Switches I get updates now, from one not.

All three send updates after I submitted a "ping" via Hubitat device control. Is there a way to script a Zwave-ping sent to a device every minute?

Download the Hubitat app