Frustration again

I want to be calm but it's amazing how frustrated I am at this moment. Yesterday, I came home and my porch light was on. it was 4pm (its set to go on at sunset -30). It had never done that before.
I have 2 bulbs in a group at the garbage cans. they were on. When I told Alexa to turn them off - Alexa dinged but the bulbs didn't flinch.
I went in the hub and commanded the bulbs off. HE delayed... a long hourglass and they went off. Later that night - motion in rooms didn't work. at all. voice commands worked. sometimes. I'd repeat them and things would come on but the wrong way (too bright, or wrong CT).
I remembered months ago when my HE was horrible and untrustworthy and I felt 'best reboot'. maybe the power failed and caused the confusion.
After the reboot, things were definitely not better. So what changed? I hate to blame things but you have to go with the obvious. I had worked on 2 things - one - I increased event and log values for a virtual bulb so I'd get more data in a hubigraph. the second was I had begun trying a beta tool called Computer control.
So I ripped computer control out. rebooted just to really get a clean reset. Things seemed better but then a kitchen group of 2 bulbs in the same fixture - one came on the other didn't during a simple motion rule.
Tonight I stopped talking to Alexa and only used my laptop to run the HE via a dashboard. I have 4 bulbs in the backyard patio - 2 are 7' from the HE, the other 2 are about 18' farther.
All 4 bulbs came on but each a different color. I use a BPTWorld app to randomize the color of the group and it had never been out of sync before.
Opening the dashboard to all lights I tried to hand change each bulb to the same color and level. When I dragged the scroll to 100% it would pop back to 99% for 2 bulbs. the other 2 accepted the 100% command. I hand entered the RGB value on each bulb but the display on dashboard tile wouldn't catch up. I'd open the bulb and set the color and it would change back. Issuing commands via Alex to set the bulbs as a group would net me 3 bulbs changing but not all 4. If I told Alexa to turn off the group - 3 would turn off but not all four. sometimes.
The logs reflect all of this - it just looks bizarre. absolutely frustrated when I have no tools to determine what has gone belly up. No hardware changes no battery problems - i've had a clean log error free (well. almost) for weeks. Where do I begin to debug this insanity!?!?!

I've just rebooted the hub again.
So far so good. Earlier today in response to help I was getting I posted a hubigraph that had datapoints. I was trying to highlight an odd data point that hubigraph was reporting:

Now. the same graph (well - with newer points added) looks like this:
I can't thing how a set of datapoints could change - unless it's corruption in a database or something.
Also, i remembered that when I first sat down and used web gui to HE to turn the backyard bulbs off I got a 'ERROR 500' . it said to refresh the page, I did - and the page DID display. that had never happened before also.
Isn't there a diagnostic app ? can it check database integrity? what about a pinger app for all the devices in the net that gives a rough idea that everything is answering? Surely these tools must already exist and I'm just too dense in my use of the HE. Does changing the Event and log entry values from 100/30 to 500/250 cause some heavy load? I thought 2000/300 was standard? (I downsized the values long ago as it was suggested by another user). Is there a processor load diagnostic that would show I've overloaded my HE? I need to step back on this. argh.

Can’t remember what your data points were (do remember reading the post), but your symptoms sound like communications issues (zigbee or zwave mesh). Could also be cpu load but not as common. The 100% v 99% isn’t a concern as some devices use 100 instead of the 99 max in the spec.

Couple of things to consider doing:

  1. look at the Runtime tab to determine if you have an app or device that is logging a significant amount of your processing
  2. consider monitoring your cpu load and memory to see if those correspond to your issues - could either do this using the http endpoints or by using the Hub Information Driver

Did you take a backup/have one available from before you loaded the apps and things started to go wrong.
If so maybe try a soft reset and load this backup.
This should at least let you know if your recent changes started your issues.


You’ve rebooted, but have you shut down and pulled power? Rebooting doesn’t restart the radios. If you haven’t already done it, shut the hub down and unplug the ac adapter from the outlet for about 30 seconds.

1 Like

Good morning.
Well. I wish I could explain what just happened. I can't and probably never will. I luckily had Hub Info device installed for a previous reason (clearing problems left in attributes from device driver changes) - hub is reporting 3.5% processing (last night it was 2.8%) I don't graph it so can't describe the long term curve.
Mem usage is minimal with 346864 KB free. DB size is 64MB. and temp is 112F. nothing there I suppose.
After I wrote my rant I watched a movie and ignored the house. When I went to bed, I couldn't get my 'go to sleep' to work and took my laptop to bed and tried to hand command things off. Finally I got up, walked around the house and turned things off by hand at the switches.
I restored the backup from 2 days ago and commanded the Zigbee channel to change from 23 to 16 and went to sleep. (regardless of recommendations, 16 had worked well previously for me 2-3 weeks ago while playing with XTCU I had changed to get a zigbee device working)
This AM I turned switches back on as I encountered them (I think the garage is still off) and everything is working normally AFAIK.
The note about Reboot given here, I did not know. Next time this happens I will remember to cold boot).
I keep local backups everyday stored to a folder because of my fear of corruption that seems to occur commonly to others.
I find the Diagnostic button in Settings to be useless (or at least mis-labeled). It shouldn't be called Diagnostics - it should be called Maintenance. There are no diagnostic tools on that page.
There should be a diagnostic button in Settings that gives a redlight / green light report. A user shouldn't need to accidentally have loaded an obscure driver to have hub statistical and performance data available. There should be guidelines in this report that says 'common database is xxxx to xxxx' etc for the different performance characteristics. I understand it's not a static value but at least give a guideline of what is not good.
For now, I'm going to let it stand for a few days and not touch. I didn't realize how much I'd gotten reliant on things working - like a light going on when I entered a room. When it doesn't work - it's absolutely uncomfortable.

@thebearmay - I looked at runtime stats and have some things I can tune up - but nothing grossly out of the ordinary.
Re: the 100 v 99. I had heard about that and always stayed unconcerned -but this morning all bulbs are at 100%. all bulbs are the exact same driver, bulb model and literally came out of the same package. Seems odd 2 could go to 100 but not all 4. I'm not bothered by this as much as it was symptomatic during a failure I was in the middle of. The instructions on the Hubitat support was to document everything so you were providing useful feedback others might use, I was trying hard to do that. thanks for the effort- I DO appreciate it!

That behavior with the bulbs could happen if the firmware was different in the 2 that go to 100.

darn. nope, not a firmware issue...

What model are your bulbs? Sylvania Smart+?

(apologies if this has been asked already)