First upgrade problem

Never before had an upgrade issue. Just tried with - hung at the rebooting screen ("This screen will redirect to the startup page in a minute,"). After several minutes, closed the window, opened a link - connection refused. It would ping. Waited 15 minutes (never had an upgrade take near that long). No change. Finally power cycled, it came back up with the old code (

2nd try was a charm, at least I didn't end up losing the config, as has been reported elsewhere.

Just sayin'. There seems to be something different about this one.

1 Like

There is something different. The update includes a database engine upgrade, users should download a backup before proceeding with installing the update, in case something goes wrong. There have been very limited number of incindents, so we don't expect users to encouter any issues.

1 Like

No, something different in the sense that it's less reliable than others in the past.

1 Like
Just wanted to report I'm encountering an error when attempting to access the new mode manager after adding and importing from legacy. When clicking on the app i receive:

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Cannot execute null+[4]

Log entry: errorjava.lang.NullPointerException: Cannot execute null+[4] on line 188 (method mainPage)

It does show the proper mode enabled on the apps screen currently, but i didn't want to start removing the app or messing around with this further before checking on this error with the community.

I found that this upgrade was a lot longer than prior ones. Make sure you give it a lot of time before thinking there is an issue.

Had the same problem after I've imported my legacy. The import seems to be not correct. Rebuilding Front scratch was easier and now everything works. Remove the app and start over. Not a nice solution, but it works.

@bravenel @bobbyD @mike.maxwell

Could you show a screenshot of the Mode Manager Legacy page? @Vincent_The_Staat the same please?

Verified problem seems fixed for me in! I can get back into mode mgr 2.0 details!

  • Fixed error on some Mode Manager Legacy imports on line 188.

Beautiful! Very fast. Thank you! :+1:

Just in case the legacy mode mgr screen is needed:

Sorry, I was to fast and deleted the Legacy Data directly, because I thought, everything worked out fine... :pensive:

1 Like

No worries. This bug was fixed in Release

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.