Fibaro wall plug (FGWPE/F-101)

I've got a Fibaro wall plug that pairs and turns on/off fine with the built in driver but it is not reporting any power, It also seems like it is not possible to set parameters

Data for the plug

I get this every time I try to set a parameter so it seems like the original setting is always "null"

[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:30.890 [warn](http://hubitat.iot/device/edit/385)There are 9 pending changes, please click the Save button again.
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.992 [debug](http://hubitat.iot/device/edit/385)CHANGING Switch On LED Color(#41) from null to 5
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.987 [debug](http://hubitat.iot/device/edit/385)CHANGING Power Overload Warning Threshold (Flashing Violet LED)(#40) from 80 to 18000
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.982 [debug](http://hubitat.iot/device/edit/385)CHANGING Power Overload Threshold(#3) from null to 18000
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.977 [debug](http://hubitat.iot/device/edit/385)CHANGING Remember Device Status Before Power Failure?(#2) from null to 0
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.973 [debug](http://hubitat.iot/device/edit/385)CHANGING Include Energy Used by Wall Plug Device?(#15) from null to 0
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.968 [debug](http://hubitat.iot/device/edit/385)CHANGING Energy Reporting Interval(#14) from null to 60
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.964 [debug](http://hubitat.iot/device/edit/385)CHANGING Power Reporting Interval(#13) from null to 60
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.960 [debug](http://hubitat.iot/device/edit/385)CHANGING Energy Reporting(#12) from null to 10
[dev:385](http://hubitat.iot/logs#dev385)2021-03-18 11:01:28.922 [debug](http://hubitat.iot/device/edit/385)CHANGING Power Reporting(#11) from null to 1

I've looked at a couple of other posts with similar issues but they all seem to have been solved by an Hubitat update. Is it possible to find the built-in driver code somewhere or is that closed source? I don't have any coding experience but I figured I could have a look at the parameters the hub is sending and compare them to the ones listed by Fibaro.

1 Like

I want absolutely to revive this discussion as there still is no solution. European Wall Plugs (this is EU Standard plugs, NOT the British version) from Fibnaro just don't work. They probably are the most used wall plugs used in the EU.

I contacted support already, but they sent me back to the forum. Several other posts on this topic offer no solution, not even the use of the 'Dome on/off'-switch driver which is suggested in one of the posts..

Come on Hubitat you can't ignore your growing base of EU-customers and serve teh British only !

Frank

1 Like

Doesnt it work with build in Fibaro wall plug driver?

For on/off, yes. Everything else, no.

I gave the ones I had to my brother who has a different hub so haven't tried it in a while.

Ok, my bad, on off works, other not.

Anybody has written or has knowledge of a driver for these wall plugs ? Come on guys, this warm and friendly forum must have a solution for this, right ?