Fibaro Motion Sensor ZW5 - add auto-inactive command

A couple of times my Fibaro sensor has either not sent the inactive, or the signal has not got through, leaving it set as motion=active sometimes for days on end. This means a) it won't detect motion again while it is already in that state and b) I can't use it as part of a motion zone controller with false alert reduction as that probably means only one more item has to go active and we're woken by sirens.

What I am requesting is for an option for the driver to automatically set the data to inactive after certain time.

Wouldn't that sort of defeat the whole purpose of the device?

Have you checked the battery? For me, that has been the cause of motion sensors that stay active.

1 Like

It's fine, it's giving temperature and illuminance every hour like I set it to do, and I can physically stop it saying Motion Active by walking in front of it. That event doesn't show, since the driver considers it already Active, but a minute later the Inactive event comes through, then it's ok again for a while. I am not trying to use it as an occupancy sensor therefore its ok for it to fake the Inactive when it doesn't get the actual one, and won't defeat the purpose. I only need one active event per episode.

I am assuming you have tried adjusting some of the settings available on this device?

Can you point out a particular one that will address my problem? I didn't see one when I've looked, some drivers do that have that option, but this does not as far as I can see.

Is the old Z-Wave FGMS-001, or the newer Z-Wave+ FGMS-001?

Truly sucks that they both have the same model number, but I had the older one get stuck on active all the time. I tossed it out and replaced it with the z-wave+ version.

The plus. But it's nothing that a little driver kludge couldn't fix - I don't think it's the device itself getting stuck on active, because it sees and responds to me when I actually go out to it and then sends its stuff. My theory is it's just the communication didn't get through to the driver - at what point it goeswrong I don't know

Much more likely, to the hub. I've never known the hub to receive data from a device but not pass it along to the platform/driver.

There's an easy way to test that: enable debug logging, then see what comes through. There are a couple options Z-Wave devices could use, but with a device this old and a driver meant for it, it should probably catch the most likely one (BasicReport?). You'll see a "Skip:" line in logs if not.

My guess is that this isn't really what's happening, and there is likely some device problem or mesh oddity, but at least this could be ruled out. :slight_smile:

1 Like

Doesn't debug logging turn itself off after half an hour? This problem has only happened twice. It's just that when it does happen it can cause problems with the applications I am using it for. I think really I can solve this if it is possible to write my own app that is triggered by it going active, waits 2 mins then forces the data state to inactive. Just thought it would be handy to have that faked inactive as an option on the driver itself - if Mike or whoever found time on his hands.

Unless RM lets us force a state on a device? Nope I can only use the commands that are already on the driver - Refresh and Configure :slight_smile:


Debug logging does get turned off after 30 minutes by default, so for an intermittent problem, it may not be easy to use (and is probably not the problem in the first place, but who knows). You could maybe trick it by shutting down the hub for a couple minutes before and after the scheduled job to turn off the logs....

I'd guess that this request is highly unlikely to happen in a built-in driver. Your best bet might be an intermediary virtual device or a custom driver, assuming the device itself cannot be "fixed."

I am going to try it with the generic z-wave motion device for a while and see if that does what I need. I didn't get an error logged when using Configure on the generic, which is a hopeful sign.

That syncDevice error is related to the beta you're running, BTW, not this particular issue. :shushing_face:


I haven't experimented with those - I just noticed that there were quite a few settings.

Hello. Curious to learn if you found a workaround for the issue you experienced? I am having the same issue. I have 2 - ZWave+ ZW5 Motion sensors and they both exhibit the same issue with my C5 HE ( i.e no report of Inactive.

Well the change to generic did fix that problem but I have just found out there have been no events since 10 days ago. Not sure if the battery has gone or it got wet. But yeah that particular problem was solved that way.

1 Like

One of my ZW5's would not consisently report motion active and the other is intermittent on reporting motion inactive. For the later I have gone the route of virtual multisensor and a rule to ensure the inactive state happens. Doesn't solve the problem that the Fibaro will not report motion active again until I power cycle it (or possibly after it refreshes its config daily). For not reporting motion, I have followed the other thread in the Community here on using the Basic Zwave tool to change some parameters the Hubitat driver does not see and/or handle correctly. I am monitoring to see if that is the solution -- too early to tell. P..S I see there is a new version of firmware (3.4) out but from what I gather it is not available for non-Fibaro controllers/hubs.