Fibaro FGS-221 relays - HELP

Our VERA hub has died so we have installed a Hubitat C-7 hub

I got it working with some zwave devices including door sensor & socket.
It made sense and I had it switching on the plug if the sensor switch opened etc. Basic but it worked with modules reporting their correct state.

I then went to install the Fibaro Double Relays FGS-221 we have (lots of them)

There is no included driver so I selected Generic ZWave/Generic ZWave plus multi switch

This allowed us to turn the units on and off, but when using an attached switch the status is not updated on the hub. The system uses IR detectors connected to the relay switches which is then used to turn lights on etc. So it is important that the correct status is reported.

I found an online driver for a Fibaro FGS-222 double relay switch (only 1 number out) and have installed that. The device works in devices, switching the relay but rather than create 2 child devices which I can add to the dashboard it gives extra buttons on the parent device. I can’t add this to the dashboard.

I tried using the included single Fibaro switch driver to see if I could at least get it working as a single relay but it doesn’t work either. We don’t want to buy loads of new relays when the current ones are not broken.

Can anyone help me.

sounds like what happened to me- ten years with vera then it joined the brick-club.

Must say, the first few weeks were strange being force migrated to hubitat but (so far) it blows the vera away.
I had two of the older "non plus" z-wave units (assuming the "FGS-221" is the older version of the "FGS-222") that i couldnt get to work with hubitat. Appeared working one minute and the next it went awol.
Bit the bullet and upgraded to the newer FGS-222 z-wave PLUS units and (so far) all works well. Seems that was the only option.
It will show up with some extra child ins/outs that seem to be of no use but once you identify which are the "useful" ins and outs you can rebuild your system.

With mine i have two inputs and two outputs, of which i'm only using one of each

i have a DBxxx temperature sensor connected. Guess the analog inputs are used if the unit is configured as such, therefore making the digital inputs redundant, i guess?
Similarly, i've not found the "internal temperature " to produce anything meaningful- perhaps this requires an additional sensor also.

follow up-
i had to install download and install a custom driver (you may already know this or have done this) I dont, however, recall if i installed one driver that created the other instances or if i had to install them all separately, but they appear in the "drivers code" section lke this:

Hi @KevC
As your devices are not z-wave plus but rather a regular z-wave I suggest you go look at the z-wave poller app in documentation.
I think this will solve your issues.

is this a suggestion or a solution from your own experience of employing the z-wave poller app to restore full functionality to the older device we speak of?

This is only a suggestion as I do not own any older non plus z-wave devices.
But I think this app was created to assist in these exact situations.

i stand corrected and apologies- the FGS-221 is a completely different unit to the FGBS-222
i believe this is the item the OP referred to:

i was thinking of this:

sorry for any confusion

Thank you for everyones help. I have installed the ZWave poller App. I now have the option of dual switching no status updates or a Single switch with status updates. With this option we will only have to purchase a few new Zwave plus modules rather than replace all of them.

Many thanks