Fibaro FGK-10x w/ Temp Probe as a Pool Thermometer

Has anyone been able to to get this device to work properly with HE for temperature reporting?

I have the DS18B20 probe attached to it and I really only want to use it for temperature reporting for my swimming pool, but no matter which driver I use, I cannot get the device to report whether the contact is open or closed and the temperature is also not reported.

I have used the Basic Z-wave Tool driver to get a report on all Parameters and Parameter 15 is set to 0 which means that the device does see the temp probe.

I have tried the following built-in drivers and I all I see are errors in the realtime log.

-Fibaro Door/Window Sensor 2
-Generic Z-Wave Motion/Temperature Sensor

I have also tried various versions of the ST drivers which have been posted on other threads and the ones that I have gotten to save without errors also don't communicate properly.

If anyone has gotten the HE to successfully talk to the FGK-10x, I would appreciate it if you can post which driver you are using.


I had two of them that I could not get to work either. One would report open/closed about 90% of the time, the other nothing. Neither would report temperature at all, with or without the proble. Used every driver I couild find.

I think it was because the ones I bought were from some older stock somewhere that had an older firmware on them and would not let them work with HE. Didn't work on ST either for that matter.

What errors do you see in the logs?

Are you able to get it to work without the probe attached. So just as a contact sensor?

I tried one of these also with no luck. I ended up going with a sonoff th16. Working well for pool temperature and power to my heater.

@gavincampbell I had originally connected it without the probe and basically nothing shows up in the current states. If I use the Fibaro Door/Window Sensor 2 driver, the logs say the following.

dev:3542020-06-12 09:46:52.573 am warnThere are 8 pending changes that will be sent to the device the next time it wakes up. You can force the device to wake up immediately by keeping the cover of the device on and pressing the TMP button on the bottom of the device.

dev:3542020-06-12 09:46:52.464 am warnTemperature and Battery will be requested the next time the device wakes up.

When I wake up the device, it just repeats the message.

When I bring the magnet close to it and then remove it, I get the following log messages...but nothing shows up in the Current States

dev:3542020-06-12 09:50:17.871 am debugignore: BasicSet(value:255)

dev:3542020-06-12 09:50:17.757 am debugignore: BasicSet(value:0)

I also performed an exclusion...factory reset it...installed the probe...performed an inclusion...and the same things are happening.

@gassgs I actually have a Qubino Flush 1D Relay controlling my pool heater and I know I could get a Temp Probe to connect to it, but then I would need to drill into my pool plumbing to connect it and I don't know how to properly get that probe in the PVC, seal it, etc..

That is why I had an idea of using the Fibaro w/ temp probe which I could mount to the underside of my diving board with the temp probe going into the water. I actually already have an Acurite Liquid & Soil probe already mounted under my diving board with probe inside the pool, but the Acurite hasn't been able to connect to HE for a few years already since Acurite discontinued their old hub and the new Access Hub won't connect to HE.

My ultimate goal is to have a virtual thermostat in HE so that I can control my pool heater with my Qubino, but every idea I have had for monitoring pool temp has not worked out.

These logs are normal.

Its a sleepy device so it waits on it to wake to send updates.

The BasicSet values are a good sign. It sends those to mark the device as open and closed.

Can you try the driver here? See if it reports open/close.

You can get longer cables for the temp probe. I have the temp probe attached to my pool ladder.

I also use a virtual thermostat that I setup in HE to use with google home.

I had tried that driver earlier and just tried it again. I get even more errors with this one and no additional state variables.

See errors below.

That version of the driver is from 2017. There are newer versions of the driver in 2018, but they are for ST and I can't find anyone as of yet that has ported that newer driver for HE.

dev:3542020-06-12 11:30:59.719 am errorgroovy.lang.MissingMethodException: No signature of method: is applicable for argument types: () values: [] Possible solutions: run(), run(), any(), is(java.lang.Object), use([Ljava.lang.Object;), any(groovy.lang.Closure) (off)

dev:3542020-06-12 11:30:57.595 am debug++++++Last Common Configuration Command SENT++++++

dev:3542020-06-12 11:30:57.589 am debugcmdBlock: [8611, delay null, 8002, delay null, 8408]

dev:3542020-06-12 11:30:57.584 am debugcmdBlock: []

dev:3542020-06-12 11:30:57.579 am debugConfiguring - Common Part.............................................

dev:3542020-06-12 11:30:57.574 am debugdevice.Configured: null

dev:3542020-06-12 11:30:57.566 am debugdevice.ZW5: null

dev:3542020-06-12 11:30:57.559 am debugdevice.ZW5set: null

dev:3542020-06-12 11:30:50.383 am debug++++++Last Common Configuration Command SENT++++++

dev:3542020-06-12 11:30:50.377 am debugcmdBlock: [8611, delay null, 8002, delay null, 8408]

dev:3542020-06-12 11:30:50.325 am debugcmdBlock: []

dev:3542020-06-12 11:30:50.319 am debugConfiguring - Common Part.............................................

dev:3542020-06-12 11:30:50.314 am debugdevice.Configured: null

dev:3542020-06-12 11:30:50.306 am debugdevice.ZW5: null

dev:3542020-06-12 11:30:50.299 am debugdevice.ZW5set: null

dev:3542020-06-12 11:30:43.562 am errorgroovy.lang.MissingMethodException: No signature of method: user_driver_JJG2014_JJ_s_Fibaro_FGK_10x_ZW5_Handler_496.both() is applicable for argument types: () values: [] Possible solutions: with(groovy.lang.Closure), each(groovy.lang.Closure), notify(), wait(), run(), run() (both)

The issue is that my pool heater is quite a ways from the pool and even if I found a cable long enough, it would need to run across my pool deck and I am not interested in cutting through concrete. Also, I am powering my Qubino with 220v and I read that you should not use the Temp Probe in water when powering with 120/220VAC. It should only be used in water when powering it with 24VDC.

At this point, I am giving up on using the Fibaro sensor as a pool thermometer.

I have found another system called Wireless Sensor Tags.

They have an outdoor unit that you can attach a DS18B20 probe and it synchronizes with a receiver that plugs into your Ethernet.

There is a thread on connecting the Wireless Tag Receiver to HE.

This is a more expensive option ($93 total for the probe & receiver) then the Fibaro, but it should get me what I want with monitoring the pool temp and I can also expand that system with additional tags to monitor temperature in other places like freezers, fridges, etc..

Sent you PM to try as last try. I use this device and a temperature sensor. I also use this device with a float to monitor water level.

That driver is for the FGDW-002 and if you tried using it with the FGK-10x and that device has overlapping configuration parameters then you may need to factory reset the device to get it working properly again...

this is my floating temp probe for pool :smiley: ...theoretically this case is waterproof but it will be extra secured (on the bottom there is a thin silicon layer).
I have only some problems with JJ's driver, can someone help me? -> Fibaro FGK-10x driver w/temp

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.