Fibaro FGBS-001

Anyone using the Fibaro universal binary sensor? I’ve got one on my ST setup that I want to move over to HE but can’t see any drivers for it.

yes i have and i have it working but I still need to work out how to get it to create child devices. until then it works in webcore for what i need it to do

Think this is it

1 Like

Ah ok many thanks @BorrisTheCat i will have a look, what have you changed? that’s the one from ST?
Yeah i would need it to see all 2 x wired contacts and 2 x temp sensors as thats how i have it in ST. It would be great if we could get the child device bit working, don’t know if anyone else is able help with this.

Yes it's the one that I was testing I've in ST that automatically creates child devices if they are connected. I have changed the commands so that they work over here in HE. I have also started to change the child creation bit, but I need to do some research to find out how this can get the child files over here. Hopefully there is some other DH already ported that will enlighten me on this. For now it works the same as ST for everything apart from creating the child devices. But the commands are still sent to the main DH.

Just gave it a go but i dont seem to be getting back any states of the end points. any ideas why?

Have you filled in the parameters and configured the device?

I hadn’t but just done it but same result it’s reporting nothing :frowning:

once you fill in all the parameters and click save you need to open up the logs on one tab then click update current Params. wait for that to finish then click configure.

Same went through process but same outcome. Really wish someone would make a proper driver for the Fibaro units it was a pain on ST now same on here!

It works perfectly on ST and here I havnt had any issues yet, other than the child devices which isn’t supported yet. But the device does respond you just havnt set it up correctly yet.

right 1st put a screenshot of your device page does it say active?

It reports unknown but says alive on z-wave settings.

seen reports that this isn't necessarily the latest information of the device. why don't you exclude the device and set it up again to ensure its paired correctly.

Then change the DH to the one you have created (make sure its the correct code)

then open up the logs page on a tab.

on the device page click list current parameters and make sure they come in on the logs page.

fill in all the default parameters and click save at the bottom of the page.

then click update current parameters wait for that to finish.

click configure device and let that finish.

close a contact and check the logs to see if anything happens

1 Like

Ok I got it yay :+1: third time lucky 3rd time adding it back in and got it :joy::joy: I was ready for giving up. Many thanks @BorrisTheCat. I also took out all the reference to the tiles from ST on my code.
now if we can get the child bit working… But happy for now​:grin::+1: cheers

On the topic of child devices have you seen this.

:joy::joy: yes you have seen it lol.

@BorrisTheCat have you setup rule machine to link to virtual devices for contacts and temps? i have had a play but cant work out how to do it. I cant see a way to update virtual device from states of the sensor. Maybe i have had to much wine :wine_glass:

:joy: No, not yet I have only moved 2 devices over too HE so far, a UBS and a fibaro RGBW controller using Webcore to link them. So am only dipping my toe in at the moment and seeing what works. For me on the UBS I have moved I don't need child devices as Webcore picks up my attributes, but on others I will need it, so until I can prove everything will work I'm taking it slow.

The child device is now supported so trying to get it working, fingers crossed it should be a quick fix. I will update the code link once its done.