FGBS-222 Temperature inputs lockup

Has anyone seen the DS18B20 stop reporting and lockup on one reading?
I have 4 installed and have been reading for several weeks without issue.
The values are logged to a CSV file every minute. I just noticed that all 4 sensors stopped reporting 3 days ago.
The last event date/time was 9/14 7:05pm for the sensors, same time the CSV data froze. The internal sensor's last event was at 11:52am on 9/14.
I just closed our pool for the season which has one of the 4 sensors embedded in the filter case.
That sensor has been disconnected for winter storage of the filter.
I did not notice the data had frozen until after closing. It froze 3 days before the pool sensor was disconnected.
I tried different things to get readings again: child refresh, parent FGBS-222 configure and configure check (not re-install), and finally power cycle the Fibaro.
Now two of the remaining sensors read 32.0 and the other 2 (including the disconnected pool temp) are still showing their old, frozen readings.
I had tested the system, when first installed, to see if the other 3 sensors would continue to read without the pool sensor connected and it worked.
I'm using the Fibaro Smart Implant FGBS-222 driver by christi999, but doubt that is the issue.

I just checked. (I don't check it that much!)

I have three temp sensors on a Fibaro Smart Implant.

No activity shown in Events or Logs!

There was activity today for Internal Temperature, but that's it!

I'm on a beta C-8. You?

I have yet tried to get them back on line.

Perhaps @christi999 has insight?

Edit: Last activity for two of the sensors 8/16. The other one, 8/2!
Edit2: Beta's got nothing to do with it, looking at those dates.

I just did a Configure on the parent device and also came up with 32F for all 3 sensors.

How about this?

I tried Z-wave repair and got this:
Never saw that before.
It ran for quite a bit before it came up with that message.
I'll try again, I guess.
edit: Oh, and zigbee radio did a reboot right after, lol.
edit2: The second time around, repair was successful.
edit3: Didn't help. Still at 32.

On a C-5. The temperatures may not update depending on the actual temps and the update increment. I'm reading outside temps and the tightest band, 0.1 DegC, so they should have been updating frequently. My internal is reading again after the sensor reboot, but that is it.

I'm thinking it is an issue with the Fibaro internally. Guessing if everything isn't perfect with one wire sensor network, the Fibaro locks up. May have contact them?

I'm going to try exclude/include.
Of course, I put the thing in an electrical box.
Maybe should've wired in a switch to make it easier.

Exclude/Include may have gotten it partially back.
I seem to getting readings on two of the three sensors, at least when hitting Configure.
I'm getting System Hardware failure messages on the two sensors that seemingly work, but nothing on number 3.
Number 3 is stuck on 68.

I'm thinking that sensor 3 failed and brought everything else down with it.
I didn't pay much for the sensors.

edit: Thing is, there are a bunch of little wires that I may or may not have soldered. The sensor is on a tank under thermal insulation. Since I haven't been looking at it, maybe I'll just decommission the whole thing.
edit2: Sensor 1 and 2 seem to be working.

I went away and came back.
I'm getting readings from sensors 1 and 2.
Nothing from 3.
I'll try excluding and including again and see what happens.
Next step would be replacing the sensor cable, I guess, if I go that route.

Getting a lot errors in debug log.
Sensors1 and 2.
Not sure if they were always there or not:

Did an exclude/include.
Still nothing from the one sensor.
Will try replacing sensor cable tomorrow-I think I used tiny wire nuts, so maybe connection is bad.

I had connection issues when I first set mine up. I ended up using Wago lever nuts. Have you tried the re-install to be sure the implant has all of the config changes.

Yes. Still the one non reporting sensor.

I've never heard of Wago lever nuts.

I took things apart just now and got tired of messing with the little wires.
I don't really use the info, so I ripped it out.

Perhaps to be used again for another application.

They are better than regular wire nuts. One slot per wire, come in 2 to 5 wire versions. https://www.amazon.com/Wago-221-413-LEVER-NUTS-Conductor-Connectors/dp/B06XGYXVXR

Also, the Implant wires are so fine I got Dupont male connectors to give them a little more bulk and protection. https://www.amazon.com/gp/product/B096DNYH52

I also noticed that all log entries for the implant stopped at the same time the data stopped coming in. Really seems like the implant just froze up.

Well, you're more organized than I am. :slight_smile:
Thanks for the tip.

I'm not sure how the Device Activity Monitor app works, if you were going to use it to see if logging drops offline, but it's only the child devices that stopped working. The parent was still transmitting its internal temperature.

I didn't like those persistent and frequent error messages in debug logging for the sensors that still were working. I never turned on debug logging previously, so I don't know if they were always there, or just appeared when the one sensor dropped off line.

I guess if you were writing a rule, you could check to see if it went below a certain temperature...although I've been getting 68 after the exclude/include, but 32 when it froze up, so to speak.

Actually everything dropped off, even the parent internal temp. And the first thing I tried, Get Config, got no responses. So the unit was definitely off in the weeds. After power cycle it started reporting internal temp again and responds to the Get Config.

1 Like

Just thinking of ways to get a heads up, since in your case, it's probably actually controlling something. Mine was just for display.

Not controlling anything. Main purpose was to monitor pool temperature. Added outdoor air temp, and 2 water leak detectors (the 2 analog inputs) in the basement.
Waiting to hear from Fibaro.

Download the Hubitat app