Feels like the worst decision (or why to not force delete Z-Wave devices)

That's pretty much the approach I took. Started with just z-wave closest to the hub and added one by one checking each one after its inclusion until all 61 z-wave devices have been included. At this point everything would be working fine. After that, maybe a day or two later I would do the same with the zigbee devices, then sometime after that, Hue and Ecobee, After that some of the core apps and Alexa.

At some point during the above process, things start to get wonky. Devices stop responding or don't have the right status. For example, just now I checked the Family Room Light (GE Z-Wave In-Wall Dimmer) which uses the standard Generic Z-Wave Dimmer driver, is in the same room as the hub, shows ACTIVE, On with level 25, yet the light is Off.

Been doing HA for quite some time. Prior to HE I was running openHAB, ST before that all the way back to PLC based devices. All the same devices worked flawlessly with openHAB, the platform has tons of flexibility but it was taking too much of my time so I decided to give HE a try figuring it would be a nice balance between ST an opebHAB.

The Hub is connected via cat5e to a dumb WAP/Switch which is connected to router/gateway (located in other part of house) via in-wall cat5e. The hub uses DHCP but has a static lease so it always comes up with the same IP.

Why do you ask?

It's about radio interference I suspect. Ensure that the Hub is a good distance away from the WAP/Switch, e.g. 6 ft or more

Two things come to mind reading about your setup.

That may be where a device was added that is misbehaving. Simply becuase it needs another reset or it's just now by cooincidence, a faulty device. Also, I'm not having issues with it as I previously suspected, but some still suspect the Ecobee Integration. Might be worth removing and rebooting as a test. Expect performance delays for up to 5 minutes after reboot is my experience.

I'm an IT consultant and have seen my share of problem switches. I'm currently using a Cisco 8 port that would go nuts 10 minutes after plugging it in. I replaced the power adapter and it's been fine ever since.

This is great. You have good troubleshooting experience then. I've overlooked something I should have seen more times than I can count. That's why it's great to share the details of your setup and get the community helping you examine the facts. These guys have help me with big and small problems numerous times.

Yup. It's also one of those things that's easy to overlook when thinking about possible problem causes.

19 posts were split to a new topic: Issues with Iris Smart Plugs as Z-Wave Repeaters

I appreciate all the help but think, for the time being, I’m done with HE. I’ve done everything suggested but just can’t get HE to consistently control my Z-wave devices. Although I have fewer Zigbee, they seem to be much less of an issue.

One minute HE seems to be fine and the next it’s not. One minute one device isn’t responding and the next minute it responds almost instantaneously.

Further more the interoperability with Cloud services isn’t working consistently for me. Alexa and Google home seem to never know the status of a device. You tell Alexa to turn on a device, one minute it works great, the next nothing and another time the devices turns on but she replies with the device is not responding.

I went from ST to openHAB. OpenHAB worked flawlessly controlling my devices but there’s a huge learning curve. Although I loved all the things I was learning it was consuming my time so I thought I would give HE a go. In the end, HE is much simpler platform but was spending all my time troubleshooting.

I’ll keep an eye on the community and look forward to a time I can migrate back.

All the best, Glenn

Quick browse through this topic. Did you, at any time, submit a ticket to support? I couldn't find where you may have done that, but it was a fast scan of everything. If you haven't, I would suggest it. Give them a chance to see if there's issues there that you can't see. AGAIN .. I'm not trying to overstep here, just wondered if you visited that avenue before you walk away.

I didn't submit a ticket but I did get some help from some of the support staff here. I'm really not sure what else could be the issue unless there's something wrong the the adapter or hub.

Basic example from just this moment.

Pull up the web interface from a laptop that is on the same network as HE. Bring up devices and the Family Room Desk Light (GE Z-Wave In-Wall Dimmer) which is in the same room as the HE hub and the third device included into the mesh. HE shows the light is off (which it) and the level 36. I click the on button and start counting, 1...2...3...4... the light comes on. Then after another 4-5 seconds the state changes to on and the level changes from 36 to 4. I know the level isn't 4 so I wait to see what happens but nothing changes. Eventually I hit refresh and the level updates to 20.

Here is the log:

dev:8992018-12-26 09:55:05.183 pm infoFamily Room Light - Desk is at 20% [digital]
dev:8992018-12-26 09:55:05.182 pm infoFamily Room Light - Desk is on [digital]
dev:8992018-12-26 09:54:58.500 pm infoFamily Room Light - Desk was set to 20% [digital]
dev:8992018-12-26 09:54:58.499 pm infoFamily Room Light - Desk is on [digital]
dev:8992018-12-26 09:54:36.374 pm infoFamily Room Light - Desk was set to 4% [digital]
dev:8992018-12-26 09:54:36.373 pm infoFamily Room Light - Desk was turned on [digital]
dev:8992018-12-26 09:06:52.773 pm infoFamily Room Light - Desk is off [digital]
dev:8992018-12-26 08:10:35.023 pm infoFamily Room Light - Desk is off [digital]
dev:8992018-12-26 07:31:47.284 pm infoFamily Room Light - Desk was turned off [physical]
dev:8992018-12-26 07:31:19.441 pm infoFamily Room Light - Desk was set to 36% [physical]
dev:8992018-12-26 07:31:19.440 pm infoFamily Room Light - Desk was turned on [physical]

My opinion is: you’re fighting more than one problem.

You have a slow hub. That’s it’s own problem and is usually due to a run away app or driver.

You are also fighting ZWave mesh issues and usually that’s interference of some variety.

I’m with @april.brandt - officially get a ticket started and let them look deep into your hub.

There’s so much we don’t know about your environment, like your neighbor is a ham radio operator etc

1 Like

With the exception of a two Inovelli dimmers and 2 Qubino Flush dimmers, the remaining 58 z-wave devices (58) are using native drivers and all 39 zigbee devices are using native drivers. I've removed all customer apps.

Went down this path a few times. Built out the z-wave mesh starting closest to the hub including and checking one device at a time. Then gave the network time to heal before adding more until all devices were included. Every room has 3 or more AC z-wave devices so there shouldn't have a distance issue.

I'm in the process of removing everything from the hub starting with the apps so I'll do some troubleshooting before I start excluding the z-wave devices.

Your experience is very far from normal. Which tells me you're fighting more than the usual number of problems. There's something very unusual with your situation and there's nothing in the set of clues to allow for a simple solution. I agree that you've described taking all the usual "cures."

I've deployed 5 hubs against my set of ZWave devices since 2014. I have seen plenty of issues :smiley: Nothing at all like you're experiencing. You and I have the same hub, You and I have GE In-Wall Dimmers. (Mine is ZWave (not Plus) and you may have ZWave Plus versions, which would be better than me.) The particular one I'm thinking of was first joined to a Staples Connect hub in 2014, and then re-joined to a ZStick (to OpenRemote) then ST and now Hubitat. I never experienced anything close to what you're experiencing. Again, all that implies is, you're experience is very far from normal.

If the Hub or Radio USB stick is faulty, you owe it to yourself to get that corrected before you put the hub on the shelf waiting for a future release. That's still a Support@Hubitat.com issue, as I said in my first message to you. It won't be MORE in warranty then. :smiley:

Well, that's encouraging. The reason I haven't logged a ticket is 1) I wasn't sure if the issues I was experiencing were unique to me and 2) its hard to log a ticket when your issues are so vast and varied and inconsistent.

Quick Update: I uninstalled every app, including Hue and Ecobee so all that is left is the z-wave and zigbee devices. I'm already noticing toggling and changing dim levels is almost instantaneous and consistent. Unfortunately a hub without a UI is pretty useless so I'll have to install Dashboard and Alexa Skill.

In the meantime, I'll log a case and see if support can sort out my issues.

1 Like

"WE" -- the community, have heard of these issues individually.

Slow hub, yep, heard that and now we all respond with "remove apps til it gets better, then add them back" - or we suggest contacting support who can inspect some logs and suggest apps / devices to focus on.

Hard to join a ZWave device, yep, heard that, we tend to respond "it didn't exclude properly."

Hard to pair Zigbee, yep, heard that, we tend to respond "add repeaters."

Variable response of devices, yep, heard that and tend to respond with "interference."

But ONE installation getting ALL of that at one time... very far from normal.

Logging a Ticket is the way to get some experience applied that can focus, one at a time on the issues and a resolution. Hubitat support sure seems amazing to me from this chair :slight_smile:

Last time I had a conversation with them, I causally mentioned I was seeing a problem and heads up, I'm gonna gather some logs, etc. so we can work on it. Under 10 mins later, before I gathered logs, they're telling me of 3 ZWave devices that deserve my attention. How does it get better than that? :smiley:


I logged a ticket and heard back pretty quickly. They saw some errors with the Ecolink Motion Sensor and Schlage door lock as well as the hub "searching" for a z-wave devices. They were unable to tell me which devise. I excluded the motion sensor and lock then re-included the lock.

I'm currently troubleshooting the lock since it appears to successful include but won't respond to any commands. Waiting to hear back from support on this and get an update on what they're seeing.


Classic "not securely included" symptom.

"Secure Pairing Complete: true" <---must be there or the lock does Nothing.

Do you have secure joining for everything or just for locks? From the z-wave settings page:


I would suggest having it set for locks/garage doors only. Seems to be less problem with my lights since changing that.

Just the Locks / Garage Doors.

I found a thread where several describe the same exact issue. The hub find the lock, they're able to save it but when the lock completes its inclusion process it comes back with a red X indicating that the process failed. Tried several different suggestion and about 20 attempts but nothing seems to work. This lock was previously paired with the hub and I don't recall having an issue.

Am I being punked? :smile:

found this post. Will it help?

I read some of the comments and it seems that he may be on to something. It's greek to me, though.