Failed Z-Wave Device - Troubleshooting Help

It appears that I had a Z-Wave sensor (Monoproce 4-in-1) fail overnight. This morning, most Z-Wave devices were unresponsive. Zigbee devices were fine. A Hub reboot brought the Z-Wave devices back. I happened to notice that my Monoproce 4-in-1 was reporting Zero LUX and the temperature was not changing. The sensor's logs showed no entries since 01:16 this morning. I have a webCoRE routine that runs at 04:45 which checks for Hub Alerts and Free Memory. It found no issues. I found no other evidence in the logs showing anything that looks wrong - other than the Z-Wave details screen, which showed this for this sensor:

So, I attempted to use the Z-Wave Replace function to reconnect the sensor. The attempt failed and all Z-Wave devices became unresponsive again. I shut the hub down and unplugged it for a minute. When I brought it back up (without the sensor), everything else works fine again. So, I'm pretty sure the Z-Wave on this sensor is bad and it's causing the Z-Wave mesh to fail. So, I've removed its battery and ordered a Zooz replacement. I'll attempt a "device replace" when it arrives.

Edit added: I have not added, subtracted, or moved any Z-Wave devices in over a week.

Here's my question: I was lucky to notice that this sensor was not reporting in for 6 hours. I'd prefer to not rely on luck when troubleshooting. However, since the logs didn't report anything obvious, What could I have done differently?

I run Device Watchdog. It checks for last activity on sensors and will stuff it into a dashboard tile. I have some devices set to report after 12 hours of no activity, some after 36 hours, and a few after 10 days (mostly outside cameras detecting people). A handy utility.


Thanks for the suggestion!
In addition to the webCoRE routine that runs at 04:45 which checks for Hub Alerts and Free Memory, I also use 'Device Monitor' - which sounds similar to 'Device Watchdog'. However, since it had been less than 6 hours since the sensor stopped reporting, it wouldn't have helped because I don't have my thresholds set that tight.

Yeah and honestly if you did set your thresholds that tight you'd get inundated with false positives.


FYI- Coming soon is a Z-wave firmware upgrade that brings some improvement in removing Z-wave ghosts, that you have with the Monoprice.

The update is in beta right now and should be out within a week or so...



Good to know, thanks!

Right now, I haven't tried to remove the old Monoprice sensor because I'm hoping to use 'Z-Wave Replace' when the Zooz sensor arrives - I think that they're either the same devices or at least extremely similar. So, I hope it'll work. If it doesn't, I have a bit of work to change all the existing ties to apps, etc. It might even be better to wait for the new update, but that sensor controls my 'Gloomy' lighting (everything between sunrise and sunset) and it's fairly important.

You could create a virtual device and use the "swap apps" function on the setup page to swap them all to the virtual device, then get rid of the failed device. After your new device is successfully paired you could swap 'em all back to the new zooz. That way you could correct your mesh issue before the zooz arrives. Obviously rules wouldn't work right with a virtual device but they would be preserved.


Thanks for the suggestion. Since the replacement Zooz sensor is scheduled to arrive tomorrow and the Z-Wave network seems stable now, I think I'll wait and do a Z-Wave Replace then - unless the network becomes unstable before then.

I've received some very good suggestions regarding removing the bad sensor and replacing it with the new one that's on the way here. I really appreciate those who've provided those tips and comments. Thank you very much!

But, I'd also like to get feedback on my original question: I'd prefer to not rely on luck when troubleshooting. So, if anything, is there something I could have done differently?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.