Eva Logik Dimmer (ZW39)

Hi, all -

I recently added a new Z-Wave dimmer from Eva Logik (ZW39) and I am struggling to get it to respond to any commands after successfully pairing it. I did some searching and found a few posts from 2018 and 2019 that talked about some driver incompatibility, but they seem to be resolved.

The device pairs normally, but starts is set as Device under the type at first. I changed that driver to the EVA LOGIK Smart Plug Dimmer from the device compatabilty list now I the Hubitat receiving some status and variables, but never responds to any control. It looks like the firmware is 2.02 (I saw reference to an issue with v2.01). I tried the Generic Z-Wave Dimmer as well as Generic Z-Wave Smart Dimmer without any change. My hub was running one of the earlier 2.2.3x releases already and I even updated it to the current and the results are the same.

Any suggestions or tricks to get this working? I appreciate any help you or suggestions on this. I have a mixture of Zigbee and Z-Wave devices running fine otherwise and this specific dimmer module is less than 5ft from my hub so Z-wave signal is not likely an issue.


I added one of those early this year and when included it used the builtin EVA driver with no need to manually change. If I were you, I'd try excluding, a factory reset on the ZW39, then retry the include. Mine works well although watching the log there is a lag with the descriptive Text logging when compared to my GE devices. For whatever it is worth mine shows firmware 2.00

I successfully paired my ZW39 and can control it from the dashboard. My device has firmware v2.01 and my HE C-7 is running v2.2.3.145

Forgot to mention, I'm using the built-in EVA LOGIK Smart Plug Dimmer driver

I appreciate the help. I had excluded it and rejoined it, but had not factory reset so I gave that a try and it seemed to get a bit further, but still stuck. It still recognized it as Device when it first joined and how I have more log entries, but it says "There are 5 pending changes, please click the Save button again" in the logs and I've clicked save device and save preferences a few times with no change. I'll let it linger in this state for a bit and see if something change in the communication unless anyone has any additional ideas. Thanks!

I had to send one of my Eva Logik devices back. I had 2 dimmer and 1 was very wonky from the start and wouldn’t dim properly. The other worked fine. You may want to reach out to the manufacturer.