Errors and issues with latest update and Generic Zwave lock

Hi, I am using the Yale yrd226 lock with the zwave module. Everything worked fine, until the latest update

  1. When adding new codes, I am now limited to 20, while the lock holds 100+ This has worked fine previously: 2023-08-21 13:26:05.683warnchangeIsValid:false, codeNumber 23 is larger than maxCodes of 20
    But using the Get Codes command fetches more of the codes, all the way to 250, which is what the lock provides:
    last code 250 fetched, fetch complete
    trying to fetch code:250

  2. There seems to be a mismatch in how the codes are stored - deleting a single code have deleted multiple items, with a java in the live logs: java.lang.NullPointerException: Cannot invoke method toInteger() on null object on line 501 (method parse)

I have also observed in random cases that adding a new code to an empty position will update another lock already stored. For example I seen an existing position #1 set as 1234 changing to 4444 when I added position 10 set 4444 - same error in the live logs as above

Anyone else observed this? Is there a new bug in the Generic Lock code? Anything I can do to fix/avoid these errors?

I too am having issues with my Yale locks after upgrading to .152 a few days ago. Still trying to figure this out.

My Yale locks work fine (ZWave version of Assure Lock 2) on

Download the Hubitat app