Error when setting color temp on inovelli switch LEDs

I am getting this error when trying to set the color temp (ie, set it to white) on the LED on all four of my switches. (three dimmers and a fan/light switch)


I am not sure what happened, it worked fine for months. I must have done some kind of update or something. The LED child devices are all using the Generic Component RGBW driver, which I think is how it's always been. I've messed around with changing that though, to no avail.
I did manually install the latest driver for one of the switches from Inovelli's website. No joy on that either.
Any help would be appreciated.
Thanks

What build are you on? Please show logs from using the built-in Generic Component RGBW driver.

2.2.9.130

Use built-in driver. It should work. It looks like Inovelli may not have updated their driver.

I assume you mean the built in driver for the switch and leave the child LED as generic rgbw? If so, I tried that on a dimmer and on the fan/light switch and got a different error.

The child device won't work with Hubitat's built-in driver because it implements this functionality in a different way. That way is the custom commands, setFanIndicator() and setLightIndicator() for the LZW36, or setIndicator() for the LZW31-SN (and LZW30-SN). So, you won't be able to do things exactly the way you did before.

Inovelli will need to update their drivers to support the new (as of Hubitat 2.2.6) three-parameter setColorTemperature() command. @ericm would probably be the one to ask. (That being said, if the app would send nothing instead of null, that would be probably improve backwards compatibility with old drivers, too. :slight_smile: )

If you wanted to make a quick modification yourself just to get rid of the errors, each driver should have a line that looks like this:

def componentSetColorTemperature(cd, value) {

Just change it to something like this instead:

def componentSetColorTemperature(cd, value, Number level=null, Integer transitionTime=null) {

and it should get rid of the error, though it should be noted that it will just completely ignore the "new" optional parameters (level, which they should be able to implement into this command and make it have the expected effect; and transition time, which the LED bar just doesn't support so would be ignored anyway under any reasonable interpretation).

1 Like

Thank you for explaining that. I was able to make the change you suggested in all three drivers (red, black, and fan/light) and it now allows me to set the color of the LED to white for all the switches. That's exactly what I needed.
As you said, It did break the set level aspect, but that's not something I really ever use. So this works perfectly for my purposes.
I didn't use the built in driver because it doesn't seem to have white as an option.
I really appreciate the help.

In the event you do need it: this should still work if you use it separately as a "Set Level" command (which also used to be the only way).

Download the Hubitat app