Error using Import




This error occurs for all imports. All the rules were freshly exported.

Could you be more detailed in the exact steps involved here. Also show one of the rules that you exported.

Export the following rule from the "Master" hub.
Hit 'Gear' icon. Hit Export/Import/Clone button.
Hit the 'Export Cellar....' button
image

Hit the 'Download ...' button.

Move over to the "Other" hub.
On the Create New Rule screen, hit 'Gear' icon. Hit Export/Import/Clone button. Select the file exported in the previous step.
image
Press the "Import" button. The result is:

The rule used for this demonstration is:

This is a 5.1 rule

What is 'Dehumidifier.txt' ? A local file?

Do you get the same error if you try to clone this rule?

OK, I can reproduce this error. I will look into it. I still need the answer about clone of the rule working or not.

Also, does that file exist on the "Other" hub?

Dehumidifier.txt is a local file. The file did not exist on the 'Other' hub. I added it but the error still occurred.
Cloning the rule on the "Master' hub worked perfectly.

This bug has been found and fixed. Fix in upcoming hot fix release.

3 Likes

I had this exact issue with a “legacy” rule the other day too, I ended up having to build the rule from scratch to add this to my 2nd hub.

I tried a different rule however and it worked. Both rules were fairly simple.

This is the rule that wouldn’t import.