Erratic Rule

Hate to keep posting these things, but I have another rule that doesn't make sense.

This simple rule turns on a light and sets the color based on mode. The bulb always turns on when the mode changes. Color is always correct. But about every 5th time it never goes off. And looking at events the bulb is never sent an off command. Any ideas?

Has it ever worked consistently, and if so has it been a while since your hub has been rebooted? I was puzzling over a simple rule (that had been working normally for months) that began 'missing' some of its commands, meaning that they should have been in the event log of the target device but weren't even though the app logging showed the rule had fired. Rebooting the hub apparently fixed it... for the time being. I hate 'fixes' like this since it really is no fix at all, but it is what it is.

You don't show the restrictions for the rule so I'm assume you don't have any? Is this a bulb connected to a hue bridge or a bulb connected directly to Hubitat? What brand of bulb? Can you control it successfully from the edit device page? Is there anything showing up in the logs for the device? Is the bulb actually on (aka is it just not logging it or is the device not turning off)? It would be helpful if you were to turn on logging for the rule.

No restrictions.
Bulb is direct to HE.
Rule always turns bulb on, never seen a failure to come on.
Problem it doesn't always turn off.
Bulb is controllable manually with no issues.
I look at the bulb events and it shows the on command, but when it doesn't turn off there is no off command showing. So the rule is not sending t he off command.
Again this only happens about 15% of the time.
I have done some reboots, just did another. Will see if that helps.

Can you turn logging on for the rule? Also, if you could look at the logs for the device, that would help. Turn on debugging right before you run the rule (if you can remember to). What type of bulb is it?