Enable/Disable Hub Mesh (

Does anyone know if there is something wrong with the Hub Mesh:

I didn't make these changes!

It's a bug, to be fixed in upcoming 2.2.7.


Hub mesh should only be used in a situation where you have more than one Hubitat hub, for example, the master hub is in your house and the slave hub is in an outbuilding.

If you only have one hub, you should disable hub mesh. Multiple hubs only applies to Hubitat hubs. It does not apply if you are connecting to another hub like Smartthings, Hue, Lutron, etc.

1 Like

Yes, I have multiple hubs.
The original source of this device is on another hub.

1 Like

BTW, 2.2.7 is out... this event spamming issue is fixed in it.

I'm not on the Beta list for all my units, how do I put all my hubs on it?

I've added your C5s to the beta list. 2.2.7 is a general public release now, it should be available under Settings - Check for updates either way.

@gopher.ny this screen is less than what you see is what you get. It does make sense to grey out already existing connected devices but not showing the checkbox as checked gives the impression they were once connected but something is not working properly and now they are not. Am I misreading what I see here?

Now that you said it, having a checkbox on devices that are already linked to locally is more intuitive. I'll make the change for 2.2.8.


@gopher.ny any chance we can sync labels from source hub to target that don’t include β€œon [hub name]”? Know we spoke about this in the past and hoping this is an option. Renaming devices in the target hub is painful when you have several hundred.

I'll revisit that, but no promises. I recall it wasn't straightforward at the time.


I am still getting this and I am on the latest firmware on all hubs.

The disabled/enabled intervals are random, and are sometimes hours apart. This is not the same issue. If hub mesh uses UDP to communicate, could you please try using TCP instead?

I am currently using TCP, I switched some time back because you asked me to switch in a PM in response to another thread due to this issue. Should I switch back?

No, TCP for hub mesh is as good as it gets. Something else is going on.
I'm thinking of adding user visible log messages for network connect/disconnect, but that would happen in 2.2.8 the earliest.

Okay I haven't really had any issues. The only reason I noticed this was because this light did not turn off last night as it was supposed to when mode switched to night. So I was looking at logs, the times it was disabled didn't really coincide with the time it should have been turned off, so not sure this had anything to do with it.

I have just recently switched it to using a group. I originally had a turn off switch with all the lights I wanted turned off selected in a RM rule. I switched to a group because of the added metering.

I have seen the hub mesh enabled disabled in events of other devices as well, but everything has been working so wasn't sure it was worth reporting.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.