Ecobee thermostat, offline again

I run mine in AUTO mode 365 days a year. We have a heat pump, so it really doesn't matter. We live in North Carolina, so there are too many days where we'd be manually flipping between HEAT and COOL to maintain the comfort level we've all come to expect - thus AUTO works the best for us.

I remember growing up in the Northeast...we would cover the AC Compressor unit outside for the winter months to keep snow and ice out of it. It would have been a bad idea to allow the thermostat to call for COOL in that situation. :wink:

1 Like

This is exactly what I want to do with my ecobee now that I have a tempest weather flow on my roof. Are you using flows in node red or how do you have it setup and would you mind sharing them?

I’m in Pennsylvania. I heat with natural gas and only have an AC compressor outside: I don’t put a cover on it. Haven’t needed too. At most I put a board with a brick on top of it to keep snow out.

I'm in Texas.

Really I could probably do without heat altogether, to be honest, and just turn on my (absurdly unneeded) gas fireplace the 10 nights it gets cold enough to. lol

1 Like

Yes, don't mind sharing - but my thermostat flow is too big to cut & paste into a message. I'll PM you a Google Drive link.

Thank you

1 Like

is there a way to just get notified when the Ecobee loses the connection? seems to happen 2-3 times a year.

Using the System Driver and App

3 Likes

thank you! this is very helpful. How is the != different from = ?
I searched around and couldn't find any information in it.

!= means “not equal”

2 Likes

thank you. i thought that might be the case but hadnt seen that one before.

I see the same thing, unfortunately. Ecobee.com even redirects to their home page and logs me out at login about 50% of the time I try to log in.

I'm able to get as far as logging into ecobee.com, and then clicking the ecobee integration authorization bright red text in a giant button, which opens a tab and once in a while I get the ecobee Accept button. I haven't yet gotten the accept button to do anything other than log me out of ecobee.com and take me to their home page. :angry:

@bobbyD - any update to this? It's obvious something is going on with ecobee, but as just one of their customers I've been powerless to affect any change. They just say "there's a problem with the provider that's integrated with our API".

The ecobee integration now seems fixed.

Hi,

If you need a robust and resilient ecobee implementation, my ecobee device has many robust mechanisms to avoid disconnects and can even "replay" failed commands up to an hour after an ecobee outage. The code is derived from my SmartThings implementation, but has been optimized for the Hubitat platform only.

1 Like

I had to sign back into Ecobee this morning after a firmware update. Is that normal? It got me thinking, it would be nice if I could monitor the Ecobee when it goes offline and have one of my light switch led's notify me of this. I don't see an option in RM to look at online/offline status. Is there a way to do this?

image

1 Like

Thanks, I don't have that option in my triggers. I'm using the stock ecobee app, do I need to use that other one thats out there?

You do, it’s hiding under custom attribute

1 Like

Found it, tested it, it works! Thank you both!

1 Like

I recently experienced this problem after years of reliable use. Replaced 2032 lithium battery inside and gave it a good dusting with a super soft brush. You will need to disconnect from wall mount remove two screws there are two locking tabs in the exact center where the back joins the face. Pry gently old plastic replace lithium battery give it a good dusting reassemble. Worked like a charm.

1 Like

Download the Hubitat app