Ecobee temp display


I just installed an Ecobee t-stat with voice control and added a tile on my dashboard to monitor the temp. On the unit itself it is reading 21.5 degrees C but the tile is showing 22. I assume it's rounding up??? Is there a way to have a decimal place to show accuracy/consistency?


When you change the setpoint through Hubitat, do those changes go in integer steps? Or does it increment and decrement by 0.5?

It briefly does 0.5 and then goes back to integer.

I also have the temp adjustment increment set at 0.5 in the tile.

According to googled discussions on this very question, the answer appears to be no. The thermostat will only display whole degrees, whereas it will internally respond to half-degree fluctuations and settings.

I took the liberty of checking every possible setting imaginable on my ecobee3 and found no opportunity to change the temperature display resolution.

Are you using the built-in Hubitat driver? I use the community app Universal Ecobee Suite and it has an option to display tenths of a degree.


1 Like

Yes I am.
Is there a link you can provide for the community app?

Here is the forum thread...I would check if it can be installed using Hubitat Package Manager.


What's really crazy is that the built in Hubitat driver seems to report the Hubitat remote sensors in 0.1(F), but the temperature at the thermostat itself is reported at 1(f) increments. I'm working on a rule that turns the Ecobee fan on when the temperature differential between sensors gets over a certain amount, but the 1 degree steps of the thermostat make that rule not work great. If the 3rd party driver can report in 0.1 steps, and the remote sensor reports in 0.1 steps, then this seems like a bug with the built in driver.
In the chart, the red line is the Ecobee remote sensor, the orange line is an AEOTEC Temp/Humidity sensor, and the blue line is the thermostat. The green line indicates if the fan is in "on" or "auto" mode. Some of those settings to auto/off are manual changes or from when the thermostat changed itself because of changing to a different comfort mode because of the time of day.

Welcome aboard. I have moved your other post under the original "Feature Request" thread. While there are no hard rules for our community, please take a moment and check out our community guidelines. We encourage users not to cross-post the same content in multiple topics:

1 Like

Sorry, I didn't consider this a cross post since I was just replying in this thread that I was seeing a similar issue, but in the other case I was specifically asking if this is a bug. After thinking about this thread, it made me think it might be. I guess I'd consider it a bug rather than a new feature since the built in driver is already getting the remote sensor measurement correctly.

1 Like

Download the Hubitat app