Ecobee Integration


#61

From ST webCoRE or Hubitat webCoRE? I don't know how much HE staff is going to help. The integration that allows you to set the thermostat program is a port of a ST app. Not a native one.


#62

I tried it from WebCore HE and it didn't work. So this morning I thought I would try it in ST and it works.


#63

Something must have changed in Ecobee Suite in the latest version. Someone will have to port it over to HE again.


#64

But if it was working and then now it isn't, it must have been something that they broke with the new update.


#65

Is there a latest version of Ecobee Suite? I am using 1.4.10.H


#66

Not necessarily. It could be a change in the ecobee architecture too. They've changed a lot recently. The latest version of Ecobee suite on ST is 1.6.10. Of course, someone would have to port that to HE.


#67

Hmm! Well it won't be me because I don't know how to do that.


#68

Me either. I was looking at the ST 1.4.10 and the HE 1.4.10 and there are a bunch of changes. I didn't compare ST 1.4.10 to ST 1.6.10 to see if there was anything major changed but I guess that would be the place to start.


#69

Okay, I don't know about you....but custom commands are working again from HE. I just tried Away, indefinite and it worked perfectly. Dunno...must have been Ecobee on the fritz again.


#70

Nope still doesn't work in HE. Just tested it using WebCore and nothing happened with Ecobee.


#71

Mine is working again. It got stuck thinking that I was still in Vacation mode for some reason, even though vacation mode had ended on my Thermostat a long time ago. I'm still thinking about swapping to the Centralite Pearl. If only HE had a better dashboard for Thermostats.


#72

Brand new HE owner here. 2 ecobee3 units. Having the problem with expired with token and failure communicating requiring me to manually reauthenticate the app. Looks like this is a long running bug that’s been “fixed” for some, and official status update?

I’m coming over from Wink, not ST. Never had any problems with Wink ecobee integration.


#73

I've had to reauthenticate the app twice in the last two days. Is a anyone else experiencing the same expired tokens?!


#74

Hubitat needs to read this issue with native support of ecobee or remove the app. Not a good first user experience to set it all up and then realize all the shortcomings and the authentication issues with ecobee


#75

Agreed!!!


#76

Yes, I have to continue to reauthenticate the past few days. Getting frustrating, even though it is likely not Hubitat's fault. Ecobee has been having a lot of issues as of late.


#77

You shouldn't have to reauthenticate despite what the logging shows. It does it automatically.

Confirm the device is still accepting commands before you reauthorize. The logs can lead you to think it failed but it is actually just triggering the refresh token. We will be fixing the logging to properly reflect this.


#78

Hmmm ... the automatically part doesn't seem to work. I waited for a couple of days (last week) for reauthentication to work ... but the ecobee integration app said it was disconnected from the ecobee server(s) ,,, I had to manually authenticate again.

Had to manually reauthenticate this past Sunday again, after the connection died :face_with_raised_eyebrow:


#79

Same experience here. Twice in the week that I've owned my HE, I've needed to manually reauthenticate the Ecobee app in order to re-establish the connection.


#80

For those that are manually re-authenticating, Need some additional information. Is your public IP address changing from your ISP and/or is is possible your Ecobee as also getting a new DHCP address internally?

Can you go into your ecobee.com account and under My Apps check to see if Hubitat is still authorized?