Ecobee integration setup fails

So trying to setup the Ecobee integration for the first time, and after putting in my auth code, I get a javascript error and seem unable to add this app. It opens up to present the login web auth just fine, but it's after putting in the MFA code it sits for a while (about 10 seconds) then just shows the error:
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data.

Anyone else run into this or have some ideas on what I can try?

Unfortunately, we don't currently support the MFA.

1 Like

I don't think thats the issue, as the web page presents the MFA auth just fine, but I turned that off (after seeing your post) and still get the same response, just now after I log in. At least, in Firefox it's that javascript error, in Chrome it's a No response from hub

Inspecting it, looks like I'm getting a 504 from (with some edits as I don't know whats sensitive information):

https://cloud.hubitat.com/api/{some kind of alpha numeric value}/apps/9/callback?access_token={access token goes here}code={Code string here}&state={state string goes here}/apps/9/callback?access_token={token repeated here})

Can you try removing the Ecobee app from Hubitat, then on the Ecobee side reset the password after disabling the MFA?

I never got the app to install in hubitat (due to the errors), however I tried your suggestion of reseting my password on the ecobee website. I left myself logged in on my browser and in a new tab added the app in hubitat web interface and this time instead of asking me for the credentials, it automatically logged me in and added the app, picked up the thermostat and sensors.

That was a good trick / advice. Much appreciated. Not sure if having the browser already logged in on another tab was the trick, or changing the password, but either way it worked and maybe if anyone else runs into these errors this can help them out.

1 Like

Download the Hubitat app