Ecobee Integration app error

Ecobee thermostat and sensors haven't been updating since 1/12. I try to open the Ecobee Integration app (running HE 2.2.4.158) and receive this ...

From the logs ...

app:332021-01-17 08:16:06.929 am errorgroovy.lang.MissingPropertyException: No such property: refresh_token for class: java.io.InputStreamReader on line 959 (startPage)

app:332021-01-17 08:16:06.323 am errorException getEcobeeDevices: 500, e:groovyx.net.http.HttpResponseException: Internal Server Error, data:[status:[code:14, message:Authentication token has expired. Refresh your tokens. ]]

I'm able to log into the ecobee website with no problem. Is the ecobee integration broken or is there a way to fix this? Thanks...

I had a strange issue myself two days ago with @storageanarchy Ecobee integration, Reading the error message it looks like the token for access to Ecobee is not valid.

My suggestion to log into Ecobee's site and check the My Apps and see Hubitat is still an authorized app. A year ago Ecobee did something that broke my integration and I had to remove the App from both the Ecobee portal and then re-authorize the Hubitat though Ecobee Suite.

“Auth token expired” means you just need to re-login to the ecobee cloud from the Ecobee app you are using.

I had this problem Thursday and there wasn't a way to re-login to the Ecobee app because it was throwing the error. What I ended up doing was opening my Ecobee device to get all the rules it was tied to, at the bottom, and leaving that page open then removing the device app in another page. When this was done I re-added the Ecobee app, re signed in, and re-added it to my rules that called for it. Really a PITA way of doing it but at the time I didn't see any other way. This will break your rules that has Ecobee in them which is why I left the device page open for easy re-adding of the device to the rules.

Using my Ecobee Suite, you shouldn’t have to uninstall, as it elegantly handles these authentication token expirations - sometimes without you even knowing they have occurred.

The stock Hubitat Ecobee integration is somewhat less resilient.

I agree, whenever I have a "token" error I just have to re-open Ecobee Suite and re-login. No need to remove and re-add and cleanup devices with hanging rules.

OK I checked and "Hubitat Elevation" is still an authorized application - I'm assuming the name of that hasn't changed.

I tried logging out and back into the ecobee website, but the error still appears with the Ecobee Integration app in Hubitat. I can't do anything with the app since it's crashing.

I'm going to follow the steps that @jonathanm8 mentioned and see if I can get the stock app working again, if that doesn't work I'll just remove it completely and install Ecobee Suite ...

... Removing and reinstalling the hubitat app seems to have fixed it. Thanks for all your quick responses.

The code has been optimized for the Hubitat platform only...No big monolythic custom application...

Download the Hubitat app