Echo Speaks no longer works


#1

My Echo Speaks has been working fine since I installed it a couple months ago, not even a hickup

2 days ago it stopped working
Yesterday I redeployed the server to v2.2.2, tested and working fine
Today, not working again

No errors in the log

I have tested it via the Echo device and the Echo Speaks app... nothing

Anyone else having issues?

Edit 7/28: I deleted the device, recreated it and now it's working again.


#2

Not to knock Echo Speaks, but with the new availability of motion and contact sensor you can now create virtual devices to kick of these devices and under Alexa you can tell your echo to say things based if motion or open or close states.


#3

Mine also stopped working a couple of days ago. You deleted and recreated the device - what device the echo device or the Echo Speaks app?


#4

The echo device. If you have auto recreate turned on in the echo speaks app, it will happen. Don't forget to go into each app/rule... That uses the device and reassign

Rick


#5

Well it stopped working again sometime last night.

I really would like to find an easier solution to the problem. The last time, I recreated the device and then had to go into each rule and reset the device... NOT fun

What logs, screen shots... can I provide to help troubleshoot this?

v2.1.3.128
Echo Gen 1

TIA
Rick


#6

I'm not knocking the developer, I think he's done a great job.

But why bother with Echo Speaks? With the new intergrations with Hubitat just make a bunch of a virtual contact sensors and publish them to the Amazon App. Then in the Alexa app program what you want to do if it's opened or closed.

Lastly, in RM setup a custom action that tells it to open or close when you want.


#7

Echo Speaks can do other things that you cannot do with Amazon app. You can get things like severe weather announcements, washing machine done announcements, etc by using Echo Speaks. I am unaware how you would do these custom things with just the Amazon app.


#8

I have a contact that triggers an Alexa routine that tells me there is a severe weather alert. No details, but I can follow up for those. Same thing can be done for washer done, etc.


#9

I've yet to run into any limitation.

If whatever plug or device to monitor washing machine or dryer, you just tell it to open a virtual contact sensor when you want.

Under alexa you just say when this contact sensor is open to speak "Washing Machine is done"

Here is an example how I’m taking advantage of this.

Nobody is home based off motion I open a contact sensor that is exposed to Alexa.

Alexa sees that it was opened and it tells my Xbox to turn off. My Xbox turns off.

I’ve also done, if my Lutron Remote is held down in the basement to turn my lights off and open this contact sensor which Alexa shuts off my Xbox.

I also use it for when my front door is left open. When triggered Alexa says front door is open.

Now getting off topic. I’m looking at broadlinks or one harmony hub setup in my network rack with IR RF extenders to all my tv and units.


#10

FYI, I just did a broadcast test, and an announcement test, and both worked fine.

I had to do an update a couple/few weeks ago, but it has worked fine since.


#11

In the past with SmartThings, I used the virtual contact sensors to get these announcements to work. When I transitioned to hubitat and learned that contact sensors did not move over to Alexa I was disappointed until I found Echo Speak. One thing thing I found that Echo Speak can do though is send variables as speech. That is, say you want to monitor all your contact sensors for some reason, in RM you can have echo speak that specific device name and what it did without having to create a special a routine for each contact sensor you wanted to add. You can also restrict when you want it to speak like, only when HSM is armed-night for instance.

Could you help me with doing something like that with virtual contact sensors and routines? I like Echo speak but it doesn't always work. Alexa routines were very reliable.


#12

So... Back to the issue at hand

How can I troubleshoot this w/o deleting the device and starting over?

Rick


#13

@tonesto7

From my very limited ability to tell otherwise... it appears to be cookie related.

The last cookie refresh was 10/7, approx. when it stopped working

I was able to refresh the cookie after about 4 times of selecting to refresh the cookie, it worked one time as a test and then not again. Now I can't refresh the cookie and it's still not working

Rick


#14

What version of the app are you running?

When I go into Echo Speaks app, it says

  • app (v x.y.z)
  • driver (v x.y.z)
  • server (v x.y.z)

According to the app's documentation, these below are the current versions. I don't think that is really true because if you go into the source code link, the app AND driver has a 2.6.0 version available. https://tonesto7.github.io/echo-speaks-docs/#/docs/information

|Echo Speaks:|App|v2.5.1]
|Echo Speaks Driver:|Device Driver|v2.5.2|
|Echo Speaks Server:|Heroku Server|v2.2.2|

It looks as if your server is fine, but what about the other parts of the app?

Have you tried any of the troubleshooting in the documentation?
https://tonesto7.github.io/echo-speaks-docs/#/docs/support


#15
  1. Create a virtual contact switch in HE for each announcement you want with Echo.
  2. Expose that virtual contact sensor to Alexa.
  3. You use HE custom action to set the virtual contact switch to open or closed.
  4. You create a Alexa routine that makes an announcement when that virtual switch is either opened or closed.
    Note: If you have a lot of different announcements, you will end up with a lot of HE virtual contact switches and a lot of Alexa routines. This is a downside to this method of getting Alexa to make your announcements, but it is working reliably for me. Echo Speaks, for me, was unreliable.

Here's one of my rules. vEcho-Door-Patio is a virtual contact sensor. I set up an Alexa routine that when the contact is open, it makes a particular announcement.
Alexa routines are easy to create.


#16

@tonesto7

I'm currently running

App: v2.6.0
Dev: v2.6.0
Server: v2.2.2
Config: v2.0

Today I used the Amazon log in button in Alexa Speaks, it obtained a new cookie, however still wouldn't work.

I then deleted the Echo device, used Alexa Speaks to recreate it and now it's working again, then had to update each rule that uses the device.

Sure hope there is an easier fix for this other than rolling through all this every few weeks

Rick


#17

@tonesto7

Any thoughts on this please?


#18

I'm not sure how to help as I have no control over the expiration of amazon cookies. All I do is collect the cookie returned from Amazon and use the amazon endpoint to validate the cookie every 4-6 hours.
Basically I use a custom modified version Alexa Cookie node library which emulates an Alexa app so that it can refresh it's own cookie.

Maybe some peoples cookies are expiring quicker than every 7 days.

I have no idea why you would ever have to remove a device. The structure is built so that the devices are sent the latest cookie info every 10 minutes and on cookie refreshes.

Maybe this issue will be non-existent with V3


#19

@tonesto7

Since I am not a developer, I am only saying it seems like a cookie issue, it may not be.

So once again, what steps can I take to troubleshoot this and get it working w/o having to delete the device and start over?

Rick


#20

Curious, what exactly are you using it for ?