Echo Speaks / Heroku end anxiety support group. See one solution below. πŸ™‚

Tried that as well and it didn't work either.

Found this on Line 71 of the index.js
Seems to indicate the env variable of 'ipAddress' would be checked and if not found then it runs the built in function? Is your platform case sensitive on Env Variables?

configFile.set("settings.ipAddress", process.env.ipAddress || getIPAddress());

Thank you, that worked. Now the IP shows up in the logs for the echo server and it's being passed back to Hubitat properly.

I can just mixed results with the Alexa authentication. It says everything is fine, but when I go back to Hubitat it says I need to login again. I decided to start fresh and remove the docker container and the Hubitat app and reinstall it and create a new stack/container in Portainer for the server. I'm still having the same issue with the authentication.

It's now not authenticating. I know I have the correct username/password cause I can use them in the Alexa app on my phone. I checked the logs on the echo server and I can see it fetches a huge block of text, which I assume is the cookie, but then I see this line in the logs:
1-10-2023 - 4:26:50pm debug: Alexa Login Status: There was an error getting authentication

I don't know how to get this thing to authenticate.

Do you have the correct region or login server set? Otherwise I have no idea, I have never had issues with it getting logged in. I know sometimes people have said restarting the instance/container after logging in has helped as well.

Are you mounting any volumes? If so can you share what you are mounting between the host and container?

I normally run it direct using pm2. Docker I was just messing with it on Docker for Windows. I believe I just launched it using docker compose as instructed and it seemed to work fine besides the up issue. Creating a new container from the UI let me set the variable. Never did try logging into the docker instance but it runs the same code and my native one.

1 Like

Could also make a rule to flash some lights in the house after a certain hour if that door is open.

You are correct, you designate which echo it speaks from. What I would do is create a second identical routine that speaks to a second echo. I also have lights that change colors. Although I don't use it now, I had a routine turn my one of my bathroom lights red, indicating that I had asked Alexa to turn on the coffee maker. So turning a bedroom red could cue you in quietly there is a security issue.

Excellent solution! Thanks, I'll try it tomorrow.

Ah. You’re running Docker on Windows whereas I’m running it off my QNAP NAS using Container Station (which is fairly straightforward.) Perhaps it might have something more to do with the way Windows and Dockers handles networking. I’ve had issues with networking addresses on Windows Dockers in the past.

With QNAP and Container Station/Docker, I almost always use Network Bridging and assign a separate β€œvirtual” static IP address to whatever server application I’m running. For example I keep one separate for my PiHole, another separate IP address for this, Channels, Plex, etc. So they all show up as their own β€œcomputer.”

Maybe this is completely unrelated but it could be part of your particular issue. I’d also disable any AV and firewalls on that machine just to see if it connects differently.

1 Like

Echo Speaks Server for Docker Instructions:


Well I got the server set up and looking like it right. I go to Hubitat and get as far as clicking the blue login page button and I get redirected to 'localhost:8091/proxy/' Am I missing something here? I am working on a different machine than the server app is running on.

1 Like

What platform is your echo speaks server on? Sounds like it is not able to detect the IP properly. I have some info about how to avoid that in my guide post. [GUIDE] Echo Speaks Server on Docker (and alternates)

1 Like

Using the node install on windows.

Check this post: [RELEASE] Echo Speaks V4 - #1229 by jtp10181

You should try setting the ipAddress variable

Not sure if this is going to work in the long run, but I disabled my Heroku echo-speaks app basic dyno and I still get TTS working on my setup.

I set it up late December and got charged partially that month.
Then I disabled it early January, and as you can see, I didn't get charged the full $7.

here's where I disabled it..

not sure what this error means:

metrics page:

It will work until the cookie expires, which seems to be much longer than the 5 days the app refreshes it but no one is really sure how long it will last.

I’ve seen mine still going 25 or so days after refresh (my Pi had stopped responding for some reason…).

For me, it quit working when I did something in the app around the end of December (can’t remember what) and that prompted me to setup a computer with Ubuntu. I am now running Pi-Hole, an ntp server, Homebridge (which had been running on Windows), and ES from it. Now I’m glad this happened. It was much easier than I thought it would be.


Check out Adguard Home. I switched from Pi-Hole over the AGH and like it better.

1 Like

Download the Hubitat app