Echo Speaks - Echo device "unknown"

This program seems excellent. I haven't tried it out much as I just installed it and I have one echo device that shows as "Unknown". Might you have a suggestion how to address this? Please remember, I'm not that computer savvy.

It is this device, an Echo dot, 4th generation (little ball, not large, not dot) It does show up in the device list.

All the other echos seem to have been correctly identified and work fine. (4 Echo 3rd dots, 1 Echo 8 show, Echo Flex and 1 Echo 3rd Smart speaker, and the "everywhere group)

Thank you

As far as I know, only the new and improved echo speaks v4 supports the 4th generation of echo devices. Is that the version you are using?

Here is a link to its forum page:

Thanks for replying so quickly. I think it's v3. It's the link I found and thought or hoped it would install the latest. I'm still not sure about the HPM. I don't think I have that??? These are the instructions I followed, but I don't believe I ever saw an option to select a version,

Check the first post in this topic there is a link to the docs page. The instructions photos are not current for v4 yet but you can still figure it out

When you select the version under Hubitat package manager choose the v4 beta
[/quote]

1 Like

Here is the link to HPM (Hubitat Package Manager). It is an awesome community app that makes finding and installing other apps super easy.

Thanks!
Should I uninstall the Echo speaks I have and start over? or will it update somewhere ?

The recommended approach is to install HPM as your next step. There is an option in that app that will allow you to match apps and drivers you have already installed with those available via HPM. Give that a try first.

If you select V4 from the options that you get from the match and then select the option to update (still in HPM) it will update it to V4 automatically for you.

1 Like

Excellent. Thank you so much. I'll work on that now.

1 Like

Thanks to you as well Bear.

1 Like

Withdrew mine as it was almost word for word the same as Sebastien’s. :sunglasses:

1 Like

Yes, but it flashed long enough for me to see and it helps build support.
I followed the link to HPM, it seems to have taken me to Github ...
But now what do I do... I know this may be intuitive to some, but I am of small mind...

Go to the Apps Code tab, select new app, and then import. In that dialog paste in:

https://raw.githubusercontent.com/dcmeglio/hubitat-packagemanager/master/apps/Package_Manager.groovy

and then save. Then go to the Apps tab and Add a User App and select HPM from the list presented, and go through the setup and hit Done. At this point you can re-enter the app and use it.

1 Like

I did, import, save,,, do I Oauth now?

Now, you need to install HPM. Go to Apps, ans Instal User app.

A list will come up and you will pick Hubitat Package Manager.

So, no Oauth, just go back to the "Apps" tab?

1 Like

Correct.

THANKS for walking me through this. We are making progress. I think it's installed.

2 Likes

OK! it found two of these... pick one???
I know I'm a pest.

1 Like

Pick the Beta

1 Like

I’d do a “Repair” on it after the Match, to ensure that you have all of the latest code pulled down and installed.

OK. I now see this... ???

Ok... I'll look for repair instead of update

repair is working
doing something anyway... :slight_smile:

Download the Hubitat app