Easy Help Needed with Mode Timing Conflict

Newbie to HE switching over from Smartthings. Thanks in advance for the help folks- this should be an easy one. My modes are set to time-only triggers, and are supposed to change throughout the day. But even when I manually set the mode to the correct one, my modes always get hung up on my "overnight" mode and never change. Can someone tell me what I'm doing wrong with my time triggers? For some reason, I can't embed a screenshot, so here's the modes and times:

Early Morning: Sunrise
Day: Sunrise +15 minutes
Evening: Sunset +30 minutes
Night: 9:45 PM
Overnight: 11:58 PM
Away: Don't Change (skip selected)
Vacation: Don't Change (skip selected)

That looks OK. One thing you could try is hitting Done inside Model Manager to re-initialize things (maybe it missed that sunrise subscription?) and see if that helps. You may also want to enable logging and see if Logs provide any clues.

For the ability to upload images, join the "Owners" group: Hub owners - Hubitat

That didn't seem to do it and the logs don't seem to be of any help either. It's as if it's skipping any time trigger that is based off of sunrise? Joined Hub Owners but still can't post images. Any thoughts?

Looks like the images came through!

One thing I'd do:

  1. Go to Settings > Hub Details
  2. Verify that Latitude, Longitude, and Time Zone are all correct for your region
  3. If needed, hit Save Settings and reboot the hub (from Settings > Reboot) if you made any changes
  4. Verify that Current Hub Time (as of last page load), Sunrise, and Sunset are all correct on the Settings > Hub Details page; if not, re-check the above.

Another thing that can help troubleshoot but won't really help you do anything about is taking a look at the "Scheduled Jobs" and "Subscriptions" sections on the App Status page, accessible from the gear icon. You will probably see a subscription to the "Sunrise" event; if not, that explains why, but hitting Done should have fixed that...

Hmmm. Did 1-4 as outlined above and rebooted but still stuck on "overnight." Wth is going on? Wierd.

At this point, I would just try removing and re-creating your Mode Manager instance. Keep logging enabled on the new one and look at them again if it has problems, otherwise something could have gone invisibly wrong with the old one that this would work around.

Seems to be working now for some reason. Maybe it was the reboot...