Driver request: Ecolink Firefighter (zigbee)

I think it is:

1 Like

Yes, to echo what @aaiyar stated that is the zwave one I have and it works great.

1 Like

Grr... Well that's irritating. It doesn't matter how vague or specific I make my search, I can even copy/paste the first 5 words from the listing title without any filters, but that result doesn't show for me unless I use the exact model number. However, the zigbee version shows up every time.

I've had similar experiences with Amazon, but I've always assumed it was just that I didn't hit the right terms that were in the listing, or that they wanted products sold/fulfilled by them first, but even that is Amazon in both cases here, so I'm at a loss.

Regardless, thank you. I've purchased the zwave model for now.

1 Like

@mike.maxwell Hi, Could I test your driver? I just bought it but I didn't know the zigbee version was not supported by default as it says in the compatibility list it is supported (I just didn't know it was only the z-wave version of it).

I'm not sure what to test, the Zigbee device will not trigger, its crap...

1 Like

Consider returning it for the z-wave version:

I know someone who spent time trying to get the zigbee version to work with zigbee2mqtt and then gave up.

1 Like

@mike.maxwell I factory reset it and I paired with smartthings and it works without adding a specific device handler for it. The sound is detected in the smartthings app. Do you know why?

I was not able to trigger the alarm using a real smoke detector. This isn't a software issue on the habitat end. So we're not going to put out a comparability acknowledgment for a device of this type that we can't verify.

Could I try your driver to see if I can get the event? I tried with a real smoke detector on my end. Maybe you got a defective device?

Maybe, but if that’s the explanation, then I got more than one defective device, since I tried Mike’s driver with a couple different ones I had purchased. So I think that’s unlikely.

1 Like

1 Like

I just tested it again with smartthings and it seems to work fine:

When did you purchase it? Maybe Ecolink updated the device's firmware recently.

I bought it this week. Maybe smartthings updated the firmware when I connected to it?

No. Maybe the manufacturer is now selling units with an updated firmware.

What could I do to help supporting the device on hubitat?

Maybe post firmware versions for someone who has a working one vs a non-working one?

Does Smartthings still publish their drivers? If so you could try to add the driver to Hubitat. There isn't a guarantee that it will work without doing some edits, sometimes you get lucky and the drivers just work.

1 Like

I have this for now. I will try to play with the driver that was post here in the thread

I got this error when trying the driver in this thread: groovy.lang.MissingPropertyException: No such property: ATTRIBUTE_IAS_ZONE_STATUS for class: com.hubitat.zigbee.Zigbee on line 156 (method configure) Anyone knows how to get around it, maybe @mike.maxwell ? Mike could you please check my previous post showing that the device works on smartthings. Any idea why it would work on smartthings but not hubitat?

Another thing I'm not getting any information in the parser (sound detection/battery status or temperature), is it normal or it's because I have the problem above? Do I need to register to something to get the events? This is my first experience with zigbee so I have no idea what I'm doing.

So I got everything working with no apparent error. I will publish the driver over the weekend :slightly_smiling_face: