Dome Siren stopped working with

On April 22nd, I updated my C7 hub to and my Dome siren no longer chimes or takes any actions. Today I did a test and took the batteries out and put them back in and there was one report of the battery level and then one test chime worked and then it no longer chimed again. Just to see if there was a one off I updated to right after the test that failed and still nothing from the Dome

Here is the debug log from the siren after update:

1 Like

Sounds like the batteries have gone. I have often found with any battery powered thing that if you take the batteries out and in again, or even just wriggle them around, you get one more last action out of them before they die again. Might as well try changing or recharging the batteries and then worry if it still doesn't work.

Batteries are fine. They were just replaced about 4 months ago. I got 3 years out of the first set with this device.

I'd still try changing batteries for giggles. The next thing I would do is shut down the hub from the settings menu. Unplug Hubitat at wall (not hub) for 5 mins and power back up. See if that helps. After that would be a factory reset of the siren and re pair to the hub.

I think the problem is much larger, none of the "battery" powered Zwave devices on my network are responding to hub issued commands. I just checked my front door lock that showed in a unlocked state this morning and tried to lock it and it didn't lock. If I manually turn the lock it sends the event and then shows up in the log, and the device goes back into low power mode waiting for the wake up event to take the action.

I am going to open a ticket with Hubitat just to be safe.

Did you try the power down and unplug for 5 mins? The reason I ask is because this will clear the z-wave radio. A lot of times that will clear things up? If you have done that then yeah, a ticket to @bobbyD is in order

You might also think about a soft reset and restore (down load your database to your pc and use that one to restore after the soft reset)

I can't do the hub recycle until everyone is out of the house. But I will give that a shot today.

1 Like

Have you updated the z-wave firmware to the latest as well? That is a separate action on the hub.

Yes I did the firmware when it can out with the new release.

If you suspect that an update changed the way the driver works for a specific device, the easiest way to rule out that the update caused the problem, is to restore previous working version from Diagnostic Tool. Any changes that may have been made to a driver will be restored to previous functionality. Hitting "Configure" button on the Device Details page may be required after restoring a previous version. If the update wasn't the problem, and the device is still not working as expected after update was restored, then you'd need to look at the radio. Are there any other devices working for the same protocol (in your case Z-Wave)? If you have other devices working, then it's not the radio that is the problem, but the device itself. Changes in your environment can impact both Z-Wave and Zigbee devices. Troubleshooting each malfunctioning device is the only way to identify why isn't working as expected. It could be that the device is no longer able to communicate with the hub, or some other device in your network is failing and the device isn't able to reach the hub. Troubleshooting isolated issues with one particular device can be challenging and unfortunately there are many local variables that can affect how well a device works.

Hopefully restoring the firmware resolves the problem, then we know that likely the problem was caused by a change in the driver.

Thanks, I will try a power cycle, and if that doesn't work will roll back . I have to go back a couple of releases to when it did work. Like I stated both this device which is a Z-Wave siren and my lock are battery z-wave devices and it seems that "sleepy" Z-Wave devices aren't responding to wake up packets to take action. The device will report "manual" events such a battery level or on the lock of who opened by code or manually locked.

Just a heads up the power cycle resolved the issue. Sleepy W-Wave devices are now responding to Hub activities. I am going to add a new item after a update to power cycle the hub after 30 minutes of run.

Did you just reboot it or actually unplug it from power for 5 mins?

Power cycled about 5 minutes off.

1 Like

Makes sense then. You cleared the z-wave radio. :slight_smile: