Difficulty Pairing Schlage BE469 Lock

I have 3 Schlage BE469 locks. I’ve been able to pair 3 out of 4 of them. The 4th and final lock that I was trying to pair tonight will not connect. I rolled back the recent hub update without any luck.

I also reverted locks back to stock drivers and went as far as to delete the code.

As a test, I just went to the store and purchased a 4th BE469. It won’t connect either.

Both locks I'm having difficulty with connect to SmartThings without any issue.

I’ve rebooted the hub at least 20 times so far today. I've made at least 40 attempts to pair these locks without any success. Most of the time they connect, but the lock indicates a failure to securely pair. The don't show as being securely paired and do not function.

All 4 have the same and latest firmware from Schlage (8.0).

I literally am laying the hub on top of the lock to pair.

Out of options... And it has to be for my rental unit too.. Ugh..

1 Like

Schlage locks are difficult to pair, I have them, I just keep trying until it just paired correctly, probably you can try to change the hub z wave setting to all secure instead locks and garage only, so you are forcing it, probably will do nothing but you can try, by the way, I never paired a lock near the hub, after you paired near the hub, then you move it to the correct place, how the lock will know the route to go? The z wave repair doesn't work with the lock because is a battery device...

Im easily over 50 pairing attempts. Theres a critical flaw in Hubitat when it comes to these locks. in ST they securely pair in less than 10 seconds. I hate the thought of going back to SmartThings, I hope support can figure this out.

This is not ST, HE uses their own drivers, Schlage teamed up with ST to do the drivers, this is why maybe is more complex here, by the way, did you factory reset the locks? I don't see that and apparently you had them paired with ST.

ST drivers are open source, so the HE team has full visibility to them. If you read my first post, one lock was retail new out of desperation. All have been factory reset over a hundred times between both. I'm also using a minimote as a secondary exclusion method after deleting from HE.

Ok, and no, ST drivers are not open source, only the drivers in Github(by 3rd party)are open source.

I suggest to send an email to support@hubitat.com, in this community we can try to help but not always is the best solution. Good luck.

1 Like

There are some drivers that they didn't open source, however you are incorrect on this one. The Z-Wave Lock driver with ST uses for the BE468 and BE469 locks is open source. You can find it on github here.

I already have a ticket open from a couple hours ago.

Driver issue and pairing issues are totally different worlds, you said the pairing is not complete, the driver is assigned after the pairing, your lock paired or not? If the lock failed to pair securely is not the driver, anyway you can choose any driver after you paired, even the one you linked, if you port it.

By the way, I will try to port it.
Edit, the driver need mayor changes, I'm not a coder to do it. Sorry.

I already ported that driver, minus lock code management. It doesn't help.
The lock is not completing the key exchange and is connecting insecurely only.

Further, through the use of a Z-Wave diagnostics/repeater driver I wrote, I've also determined that the lock was not getting Association Group #1 set, therefore it is unable to even be queried for MSR and other parameters. Once I set the association, the lock communicates when polled for MSR and other data points.

1 Like

This is Greek to me, but since there are several posts about the schlage lock and pairing, have you been kind enough to communicate that to support so that they might be able to address it? I'm considering buying two more schlages and I've put it off because the one i have works and I'm afraid to attempt any new pairings for schlage. And I ... have .... no idea ... what you did to make that work. :slight_smile:

MSR = ManufacturerSpecificReport, which is what you see when you pair/join a device:

Association Group #1 = Lifeline or the "pointer" back to the Primary Hub. In other words, if your Hub is Node ID 1 then every ZWave device on it's network has an pointer back to that number, 1. Without, it doesn't know where to send status packets. It knows how to respond to commands because it gets the command FROM a unique node ID.

Doubt that helps with translating, but maybe it's 50% closer. :smiley:

Are you willing to share your ported driver, please? I'm having a slightly different issue from you. I was able to pair my locks, and they are verified as paired securely, but they are very unstable. Sometimes they work, sometimes they don't. I'm getting desperate and willing to try the ported driver to see if that fixes my issue. I tried following the wiki instructions on how to port over a driver but it exceeded my technical competency.


If you got them to securely pair and configured, then I would recommend running a zwave repair, and it should settle down within a few days. Just make sure to have a repeater near by the locks to help with stability.

Done and done. That hasn't helped unfortunately. :frowning: Multiple Z-Wave repairs, and waiting, in addition to adding more Z-Wave Plus repeaters verified to be beaming, has not improved the situation by any measurable degree.

Details on all I've tried can be found here and here.

I had the same difficulty you are experiencing and took literally a full day to get all 3 locks paired, and I finally achieved this with this process. Schlage Connect Camelot Pairing Issue

I actually followed your guide in that thread on Friday when I excluded/reset/repaired all 3 locks. I do appreciate your trying to help me, however. Again, unfortunately, I'm still struggling to get the locks to behave properly.

Sometimes they lock, sometimes they don't. Sometimes they update the HE when I manually lock/unlock them, sometimes they don't. They worked great on my Wink for a long time before I migrated to HE a few weeks ago. They seem to have a mind of their own with the HE...

I did have to repeat that process multiple times, and mine too also paired and worked fine on Vera (when they wouldn't on HE), the only common denominator to when each of the 3 eventually became successful, was after pairing and hitting the configure button, waited until the logs shown tracing all 30 codes complete in the configuration process, once I verified that occurred each of mine worked fine after that.......other than that I'm out of ideas. One of them only traced about 14 codes and stopped, at which I had to hit configure again until it reached 30.

Yuck... fun times ahead for me then. I'll be traveling on and off for the next week, so I'll have to revisit this later in the month.

Thanks for the advice and feedback!

Of course.

Thank you!