Devices unreliable since

I updated recently to and can generally no longer control my devices.

Example for an outlet that previously worked that I call "lamps"

  • In the webui, the switch state generally correctly reflects the state of the device (always, I think)
  • If I use the webui (device list from the hub) to control the device it often does not work - can't turn on or off. But sometimes it /does/ work and with typical low latency
  • If I attempt to control the devices from my Google home / voice command integration (this is my typical and preferred use case) I always get a positive feedback from Google and I can see in the web UI event log that the device was sent an on/off command, but like with the hub UI, sometimes this works, sometimes it does not. The event log always agrees with the audio feedback I get from google that it heard an on/off command

I think this happened since I updated to a couple nights ago. Is there some way I should attempt to repair this? Almost all my devices are zwave/ZigBee and I haven't tested extensively but they all seem unreliable. Thanks in advance for any help!

Mimolite devices no longer responsive since update to

Is this an assertion of a known issue? I'm not sure what mimolite is or if it may apply to my devices. The one I cited is an old monoproce zwave(+?) receptacle.

My FortrezZ Mimolite devices stopped working after the update.
I was piggybacking on your post to see if anyone has seen or knows of this being an issue.

Really need to include the hub model when asking for help as there are some differences that need to be accounted for when troubleshooting.


@user719 You can also try rolling back to see if the issue corrects itself.

@thebearmay I have a Rev C-7 - I think that's the version info (sorry, I'm an infrequent reader of the forums and was under the impression this was ubiquitous enough that it need not be reported).

I'll look into a rollback, too.

No worries, it’s just that we’re tracking C-7 and C-8 issues and it’s helpful to know which you may be using. Can you tell us what the output of http://yourHubIp/hub/currentZigbeeStack is?

"Hub is set to use standard Zigbee stack"

I'm afraid I didn't do a backup to rollback to, I just seem to have db snapshots (This is probably also going to be an overdue lesson about laziness on my part, too)

I was testing with a different device this morning and it was behaving the same way as the outlet I previously described (not responding from Google commands or from the hub controls).

I then clicked "refresh" from the hub UI and saw the device flash on/off a few times.

After this, I was able to refresh the device reliably a few times from the web UI.

Then I tried controlling from Google (this time I'm using the Google Home app on my phone rather than voice commands) and they were unresponsive. After this, the web UI was also unresponsive.

I then clicked "refresh" again and after a few minutes it flashed a few times again and now the web UI works again. Currently, Google Home app, and Google voice commands also work.

Apologies if this is TMI but I'm trying to accurately describe the behavior as well as I can (at least for my own diagnosis if nothing else)

I don't really know how to interpret the Logs UI, but I seem to see this:

  • Sometimes there are a series of lines that are only successive "debug" level messages saying "on()" / "off()" that seem like they may map to the times my commands aren't updating the devices.
  • These seem to eventually hit a "refresh()" message
  • and after that, the on() / off() messages are interleaved with a lot more messages about payload processing that seem actually related to controlling the device

Your hub should be doing a backup every night around 2:00am, also you can rollback the firmware with current setup. A restore of a back up does not however rollback the firmware. Goto the diagnostic tool, http://{yourIP}:8081, to do that.

Not that kind of roll back. You can roll back the firmware update from the diagnostic tool.
There is no need to do a database reset or restore.

Use the "Restore Previous Version" button on here: Hubitat Diagnostic Tool | Hubitat Documentation

It automatically backs up every night locally.

I'm using a C5 hub, after rolling back the update everything seems to be working again. I guess it's time to complete my roll up to the C7 hub I've had for at least a year, Just didn't want to mess with something that was working.

Thanks to everyone for the comments. I did the following and something in here got my device responsiveness prompt again:

  • restored database backup from
  • updated again to
  • some forced reboots

It's possible I should have gathered more intermediate data because I'm pretty sure I was legitimately in a bad state but it seems that more or less "turning it off and back on again" did the trick. I'll spend some time trying to understand the differences in the backup / restore types but my stuff is working again.

Just curious - is the best way for people to engage with this community to go through these web pages? I love my hubitat and pay for the AWS remote access because it seems like a fair way to support the project, but I pretty rarely read the forums. I'd really like to but I spend more of my aggregated time through reddit, which isn't where most of the hubitat chatter is happening.

Thanks to everyone who replied!

1 Like

Yes. There is a very strong community of people here and generally always someone trying to help. Plus Hubitat’s support team frequents this forum.